Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-25-2005, 11:14 PM
Registered User
 
Join Date: May 2003
Location: Charlotte, NC
Posts: 31
1994 C280 Windshield wiper

1994 C280 Windshield wiper
The windshield wiper has failed again. Motor runs, but wiper doesn't. Has anyone tried the $25 reman wiper motor from:

http://oem.thepartsbin.com/parts/thepartsbin/wizard.jsp?year=1994&make=MB&model=C-280-001&category=All&part=Windshield%20Wiper%20Motor&dp=true

If not, has anyone rebuilt the reduction gear between the ww motor and the linkage? Are parts available for the gears?

__________________
GeneN
Charlotte, NC
1994 C280 135K
Reply With Quote
  #2  
Old 12-26-2005, 01:06 AM
carson356
Guest
 
Posts: n/a
Quote:
Originally Posted by GeneN
1994 C280 Windshield wiper
The windshield wiper has failed again. Motor runs, but wiper doesn't. Has anyone tried the $25 reman wiper motor from:

http://oem.thepartsbin.com/parts/thepartsbin/wizard.jsp?year=1994&make=MB&model=C-280-001&category=All&part=Windshield%20Wiper%20Motor&dp=true

If not, has anyone rebuilt the reduction gear between the ww motor and the linkage? Are parts available for the gears?
is it possible that the nut securing the linkage has come loose? have you disassembled the area?
Reply With Quote
  #3  
Old 12-26-2005, 03:14 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Good suggestion: Don't fix it until you know what to repair.

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #4  
Old 12-26-2005, 02:29 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
have you used the search function here, for the link for instructions on how to lubricate and fix the mono-wiper?
Reply With Quote
  #5  
Old 12-27-2005, 05:45 PM
Registered User
 
Join Date: May 2003
Location: Charlotte, NC
Posts: 31
Thanks for the ideas guys.

I've previously had the nut fall off from the reduction gear output. I locktited it back with blue locktite. I also lubed it as described elsewhere.

The symptom is different this time. The motor runs, but the wiper moves in fits and starts.

If the weather holds I'll get it dissembled this weekend and report back.

__________________
GeneN
Charlotte, NC
1994 C280 135K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page