Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-21-2001, 12:17 PM
Posts: n/a
Before buying the parts to fix an idle problem (dying and jumpy) I checked for vacuum leaks under the air cleaner. Found 4 vacuum lines disconnected. This could be the source of my problems!?! I reconnected them but noticed that there is a vertical vacuum fitting on the right side of the manifold between the fuel distributor and the intake side of the manifold. The rubber fitting goes to a splitter that goes to what looks like a sensor and the fuel EHA (I think). This black rubber fitting looks as though molten rubber (1/2” x ½” x 1”) was dripped onto the top of the fitting. I can’t tell if it was a splitter and melted or this rubber came from somewhere else. Is there any plug in the air cleaner cover that could have fallen out? Has anyone ever seen or heard of such a thing?

’85 SL500 Euro
Reply With Quote
Old 02-21-2001, 07:19 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I have not seen what you are talking about. You may want to snap a picture and post it on the net for us to see.

Also, I think your car would have a frequency valve system, not an EHA because of the year.
Donnie Drummonds
Reply With Quote
Old 03-12-2001, 11:33 AM
Posts: n/a
Thanks Benzmac, for answering my post. Took me a week to get a digital photo and although I have it on Photopoint, I can't get it shared. I will keep trying but could zip and email it to you directly, but not without your permission.

I have to say that I have not confirmed it, but suspect it was a fix from a vacuum leak a local mechanic made. I will confirm if so before I waste anymore of your time.

'85 500SL Euro

PS - Yes, it has a frequency valve, not EHA.

[Edited by Stevegman on 03-13-2001 at 06:40 PM]
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please - torque specs on '99 E300 intake manifold and glowplugs!!? LightMan Diesel Discussion 5 11-30-2008 04:36 PM
Oil In The Manifold Intake Of 190e, 2.6l.1988 MARIO FARIAS Diesel Discussion 4 12-22-2003 01:03 PM
Replaced intake manifold gasket and now won't start - 300 SDL tstarr Diesel Discussion 0 11-04-2003 08:11 PM
98 C280 loose air boot at intake manifold shane83SD Tech Help 2 11-01-2003 12:54 AM
103 Intake & Exhaust Manifold Specs Kyle Blackmore Tech Help 2 06-30-2003 12:44 AM

All times are GMT -4. The time now is 12:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page