Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2001, 01:56 AM
ericd
Guest
 
Posts: n/a
Hi- We have a 79 280CE w/110 Motor. When you start the car it revs real fast, then it slows down, then revs real fast again. The oil pressure will shoot up to 40, then back down to about 30, then 40 again with it's in Park. We are going to change plugs, wire, distributor cap and button. But is there an idle speed setting that we need to be concerned with.

We are restoring this car from being in the barn "literally" for 6 years. The interior is primo and the paint/etc is great too. I'm sure we just have a few bugs and dust bunnies to flush out. Any advice would be great.

Also, the sunroof is very sluggish, you have to help it open and close. Any clues there.

Thanks in advance....

Eric D in TN.
Reply With Quote
  #2  
Old 02-22-2001, 10:35 AM
arochard
Guest
 
Posts: n/a
My guess would be to start with the fuel/air mixture on the carb, and work your way to setting the timing properly.

Also, the gas in the tank is probably really stale, if you can, try and fill or top it up with really high octane gas (Sunoco Ultra 94) or something similar for the next few fill ups.

Hope this helps.

AARON ROCHARD

1976 230.4 W115
Reply With Quote
  #3  
Old 02-22-2001, 11:23 AM
ericd
Guest
 
Posts: n/a
How do you adjust the mixture on the carb? Also our is the fuel injection model does this tip still apply? I have a service manual and it talks about two screws on the carb, is this what you mean? Thanks for the reply...
Reply With Quote
  #4  
Old 02-22-2001, 12:03 PM
arochard
Guest
 
Posts: n/a
If yours is fuel injected, I'm not sure if this still applies, Ill check my Chilton's manual and get back to you. However, it still sounds like the timing might be off. If you're not sure about how to adjust it, I'd suggest paying a visit to your local Mercedes shop (preferably NOT the dealership, better some older guy who has worked on this model or something similar before ) If you don't have one of these in your area, try a Volkswagen or other European shop. You'll save yourself a lot of headaches !!!

AARON ROCHARD

1976 230.4 W115
Reply With Quote
  #5  
Old 02-23-2001, 08:18 PM
ericd
Guest
 
Posts: n/a
Quote:
Originally posted by arochard
If yours is fuel injected, I'm not sure if this still applies, Ill check my Chilton's manual and get back to you. However, it still sounds like the timing might be off. If you're not sure about how to adjust it, I'd suggest paying a visit to your local Mercedes shop (preferably NOT the dealership, better some older guy who has worked on this model or something similar before ) If you don't have one of these in your area, try a Volkswagen or other European shop. You'll save yourself a lot of headaches !!!

AARON ROCHARD

1976 230.4 W115
we sent it to a shop today. the timing was set high, we checked it with the timing light, hopefully the adjustments the shop does will help
thanks
Reply With Quote
  #6  
Old 02-23-2001, 10:02 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If your car is infact a 280CE, the E stands for injection. I would think that the ilde valve is faulty. This engine has an idle valve that is coolant temperature dependent. It will decrease the engine as the coolant warms.

After the valve problem is looked at, you could have the base idle adjusted on this engine.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle Speed - 1985 500 SEC awfrance Tech Help 10 01-31-2003 05:30 PM
Erratic Idle Speed johnwallace Tech Help 13 08-03-2002 02:19 PM
Elevated Idle Speed - '87 300TD jgl1 Tech Help 2 03-25-2002 07:23 PM
W126 idle speed control unit merc380sel Tech Help 7 08-21-2001 11:18 AM
UNEVEN IDLE SPEED ON 124.032 MB STARS Tech Help 3 04-29-1999 09:15 PM



All times are GMT -4. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page