Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-23-2001, 08:11 AM
rob190e
Guest
 
Posts: n/a

i have a 87' 190e 2.3-16v and it got problems!

1) it wont keep idle...im told its the idle compensator?
2) on idle the damn thing just runs extremely rich and has no top end power. i just gave it a tune up and a plug change...no good. they tell me it is the fuel pressure regulator??!!

whats up with this?! Ive taken it to 3 mech and each has a different answer. i got this feeling im being taken for a ride..,oh the joy of having a benz...!

Any help you guys can give is deffinetly usefull since in this close to selling the damn thing even though i love my 1st car.
thanks
Reply With Quote
  #2  
Old 02-23-2001, 09:00 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Rob the first thing to do is check valve adjustment & COMPRESSION! The 16V timing chain tensioner will allow the intake cam to jump time, this will cause poor performance.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 02-23-2001, 10:31 AM
dlswnfrd
Guest
 
Posts: n/a
Quit Jumping around

Rob, why not take your 190 to a Mercedes Benz dealer?
You are being jacked around by mechanics that don't know where the problem is so they just cover every aspect, parts replacers.
Do yourself and your 190 a good turn and go to the Dealer.
Our moderator suggested the intake cam may have jumped a tooth or so;
I question the cat/convertor?
Happy Trails Beep Beep from Houston!!!
Donald, El Cheapo
Reply With Quote
  #4  
Old 02-23-2001, 06:20 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
My brother had an 85 190e 2.3 and the cat got plugged up, car was smoking and had no power.

I think I would look into the cat to see if its ok.

Thats my opinion on it, and I'm not a tech.

Alon
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #5  
Old 02-23-2001, 06:56 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Never seen a plugged catalyst cause any idle problems~!
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #6  
Old 02-23-2001, 08:01 PM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
I totally missed out on the idle issue...

I was respoinding to the no power remark he made.

When the 190e my bro had had a plugged cat, the car sounded like it was gasping for air, and you could put your foot down in gear, get up to 1500 revs and it would sputter and die out. It happened on the freeway at 65mph, car just lost all power and everything.

when the cat was replaced all was fine.

Just thinking it might be a contributor tot he problem.

But your the pro MB DOC. I won't disagree with your diagnosis.

Rob, got a question for you. Where are you located? i would check the good mb shops section of the forum, you should have no trouble finding a good shop close to you if its listed in there.

if you are in Los Angeles, I know a good shop just over the hill in the san fernando valley off reseda and the 101 freeway.

Its called Mr. MB Motors In tarzana. The guy there enrique is very good, and his prices wont break the bank. he just fixed my dad's SL (Dealer wanted to put in new tranny and torque converter for $4-5000) for $900 which involved dropping out the tranny and replacing the front pump and main seal. He fixed my brothers car at the same time, which had completely worn rockers. He also adjusted the brakes, changed fluids, and checked out the whole car. Cost my bro $500 for the repair.

I'm going in on tuesday to have my springs done and suspension bushings inspected for any worn bushings, trans and engine mounts inspected, and other things inspected. He is only charging me $160 for the spring install.

My other independent who works on most exotic cars etc, wanted $250 for the spring install, so I'm saving money by going to my independent MB only specialist over my independent shop that works on ferraris, porsche, rolls, mercedes, Lamborghini, BMw, and other cars.

Spo if you are in LA, chck out Mr MB Motors in Tarzana. If you are elsewhere, check the Good MB shops forum on this site and se if someone has listed a good shop you can go to.

keep us posted on the problem, I'm curious to know what the cause of it is and what it tookt o fix it.

Alon

Alon

[Edited by Ashman on 02-23-2001 at 07:09 PM]
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #7  
Old 02-26-2001, 05:32 AM
rob190e
Guest
 
Posts: n/a
still smokin


Thanks guys. Ill look into it.

Im taking it into 1 of the main dealers tomorrow, the guy there boast he can find he problem.thing is they also boast of having the most expensive prices!

ill get back to you guys if the problem still stumps these guys along with me.

Reply With Quote
  #8  
Old 02-27-2001, 09:42 AM
dlswnfrd
Guest
 
Posts: n/a
rob190e

Good ole man, now you've got all burners on.
Have a thorough engine check and get back to us.
Happy Trails beep beep from Houston!!!
Donald, El Cheapo

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page