Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-26-2001, 07:57 AM
Registered User
Join Date: Nov 2000
Location: Knoxville, TN USA
Posts: 56
Help! Is my water pump bad?

I have a bad coolant leak at what appears to be the surface where the water pump mounts to the block. In looking through fastlane parts there are several o-rings and parts listed. Do I need a new water pump or is there an o-ring that can be changed? If so what do I need? The pump doesn't appear to be leaking from the pulley shaft as I am used to when they have failed on other makes I have owned. Thanks for any help.
Steve Short
'91 300SE sold
'92 190E 2.3 sold
'99 S420
'06 Mini Cooper S
'08 Triumph Rocket III
'02 CLK430
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
oil leak - oil in coolant Ethan Tech Help 1 07-10-2004 06:25 PM
Coolant Leak Mystery 92 500sel DaveL Tech Help 2 05-06-2004 01:37 PM
coolant leak -> paint damage? ktlimq Tech Help 4 03-14-2004 05:42 PM
Coolant Leak EstebanSPI Tech Help 3 10-28-2001 08:53 AM
Coolant leak - Stop Leak davek Tech Help 14 03-31-2001 01:46 AM

All times are GMT -4. The time now is 08:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page