Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-27-2001, 05:57 PM
Registered User
 
Join Date: May 1999
Location: Oklahoma City, OK, USA
Posts: 28
I was recently driving my 1986 300E with the heater on, fan at low speed, and temp setting about 70F. After about 5 minutes, I smelled what seemed to be burning electrical insulation. I turned the thermostat to full cold, but the smell continued. I turned off the fan, and the smell went away. It seemed that that the smell was coming from the duct work. There were no blown fuses, and no obvious problems from the engine compartment. Any suggestions as to where to start looking. The fan motor wasn't noisy or running slow. Any electrical components or harness issues you may have experienced? Thanks in advance.
__________________
Ted Beer
'91 190E 2.3
Reply With Quote
  #2  
Old 02-27-2001, 10:04 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I have seen the fan motor cause this as well as the wiper motor if there is a binding in the wiper assy.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'86 300E Aux Fan InOp d2bernhard Tech Help 10 08-16-2004 02:14 PM
advice on installing aftermarket aux. fan on my 89 300e shawncisco Tech Help 0 05-20-2004 02:39 PM
w124 300e blower fan works sometimes whair Tech Help 6 09-12-2003 05:55 PM
Help!!! The electric fan is dead on my 88 300E Peter Janicki Tech Help 5 05-22-2003 08:45 AM
Advise on 300E Fan Clutch DanielW Tech Help 1 07-25-2002 02:52 PM



All times are GMT -4. The time now is 01:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page