Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-28-2001, 08:39 AM
Dinky
Guest
 
Posts: n/a
Wonder if anyone can help me out on this ...

Lately, I've been experiencing engine pings ONLY under hard acceleration PAST 4,000 rpm. It doesn't happens below 4,000 rpm, whatever the load. Mechanic has checked ignition timing and its right on the dot. Tried retarding the ignition timing and the problem still persists. Checked CO as well and its within specs. Have not made any changes recently except for a change to a set of Bosch Platinum +4 plugs. Whats happening???
Reply With Quote
  #2  
Old 02-28-2001, 12:29 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
Get rid of the platinum plugs as soon as you can. They were not designed for this engine..go back to the copper ones h7dco! The poor spark that these platinum plugs produce cannot be handled by the 103 and 102 engines (no variable timing for starters). Everybody wants a modern solution for their cars but this is one situation where the old way is much much better!

Do a search on this forum you will get some more info. Hope this helps.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Needing Lower engine covers for 93 400e W124 rsmcmahon Mercedes Used Parts For Sale & Wanted 5 01-18-2005 05:13 PM
FS: MB W124 Engine & Chassis Manuals SteveUrban Mercedes Used Parts For Sale & Wanted 5 01-11-2005 03:25 PM
'84 M102 2.3L stumbles when cold. lietuviai Tech Help 1 12-28-2004 03:25 PM
Weird Engine Pings with my M102 2.3l-8valve W124 Dinky Tech Help 0 03-09-2001 05:10 AM
W124 Engine change over Nick 230CE Tech Help 2 12-09-2000 09:30 PM



All times are GMT -4. The time now is 09:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page