PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   1996 E320 Cruise Control Not Working... (http://www.peachparts.com/shopforum/tech-help/145507-1996-e320-cruise-control-not-working.html)

300EJust4Me 02-13-2006 04:08 PM

1996 E320 Cruise Control Not Working...
 
Well, the cruise control on my 1996 E320 is not working and I am trying to figure out the cause. One thing I am considering is the fact that I have oversized snow tires on the rear of the car. They are slightly larger than the tires in the front, and the problem seems to have initiated around the time I put the new snows on the rear. Anythoughts at the moment? I am thinking a relay.....

P.S. Getting ready to do the front ball joints in a few weeks.

just turned 84,000mi

Thanks!
Mike

BadBenz94 02-13-2006 04:51 PM

That could be the problem, too if I remember correctly you still have the M104 engine in there and the part that controls the CC is the throttle body actuator. If that turns out to be bad its big $$ from the dealer I used this gentleman and it was the fix to end all. www.4mercedes.com . I paid 400 for a rebuilt one and couldnt be happier since!
Chris


All times are GMT -4. The time now is 06:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website