Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-19-2001, 03:45 PM
Posts: n/a
This car ('72 280SE 4.5) will run beautifully when it feels like it. The problem is some days when I get into it and put the key in I get absolutely nothing! No ignition lights,no power to the windows, zilch! I thought it could be the ignition switch, but I get no power to the headlights either. Unless the ignition switch and headlights are related in some way. I'm stumped, because some days it will crank right on and run perfect. It's not the battery because I had that tested. Any ideas? Appreciate!Thanks!
Reply With Quote
Old 03-19-2001, 03:52 PM
Registered User
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,768
Sounds like the classic dirty cable ends on the battery.
They look good, but are not connecting.
Take them off and clean them up.
Also , check ground straps.
Reply With Quote
Old 03-19-2001, 03:59 PM
Join Date: Jan 2001
Location: Send me back to Atlanta
Posts: 876
Been There...

I have had the same problem once in a truck, and it was the battery connections, they looked clean but were not giving me any power, once I clean them no more problems. I would check, ground cable also..
2000 Ford 7.3 Powerstroke 4x4
2006 Mazda Tribute
1983 Black 300 D (donated to charity)
1993 Teal 300 D (160K) Sold
"I love the smell of burnt diesel fuel in the morning, it smells like ....VICTORY"

Semper Fidelis
USMC 1973-1976
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300SL Power Drain hifeverz SL Forum 1 05-03-2004 10:51 PM
Maine Bans sale of new diesels..... KeroseneKar Diesel Discussion 35 02-28-2004 11:49 AM
power windows and mrrors remain dysfunctional after battery replaced. ericj51 Tech Help 3 02-11-2004 07:30 PM
Battery Venting Cloud Of Hot Acid TOM CONWAY Tech Help 2 11-03-2002 07:04 PM
Help! 94 C280 lost power steering, and ABS and battery lights on... hancheng Tech Help 4 08-14-2001 02:16 PM

All times are GMT -4. The time now is 02:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page