Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-19-2001, 09:43 PM
mike bognar
Guest
 
Posts: n/a
have acguired a 97 500sl that got wet as far as the floor pan. transmission stays in second and the top does not go up. help!!!!!
Reply With Quote
  #2  
Old 03-19-2001, 10:29 PM
Registered User
 
Join Date: Jul 2000
Posts: 638
water logged sl500

I hope you got a real good price and an extended warranty.

First thing is to drain all the lubes and check for any signs of water. It's the first few drops out normally.

If there is any 'mayonaise' you need an immediate flush,flush, pray.

Quite possible one or more of the electronic modules got wet.

Tranny control is electronic. Top system is horrendously complex computer controlled system. Good luck.

Dealer diagnosis is the best bet to find out what's bad.
Reply With Quote
  #3  
Old 03-20-2001, 07:05 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
mike,

How wet is as far as the floor pan? Was it a complete under water car or was it a severe rained wet car?

I had a top-closing problem about a half-year ago with my 300SL and this turned out to be a hydraulic "pod" that only cost US$40 (with additional repair costs/mechanic hours US$450).
The top of the R129 SL is complex enough to let the dealer take care of any hydraulic opening/closing problem...

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #4  
Old 03-20-2001, 10:53 PM
mike bognar
Guest
 
Posts: n/a
wet 500sl

MBENZ thanks for the reply. The car got wet in a rain storm. I drove the car 150 miles after acquiring it and it runs excellent. Initially it shifted ok, but sluggish in first gear and then it went into safety mode {2nd gear}. I think the trans computer is under the passenger foot well and this was the height of the water intrusion.Someone said that there is an additional fuse block besides the one in the trunk and under the hood. I also think that the top control computer is also under the footwell. Any ideas? This is my second Sl {87 560} and I now also own a 320ml which has been a great vehicle. Unfortunately my dealer is 1500 miles away and has not been too free with any assistance. Any way to check the tranny fluid level?If I could get the tranny working ok , I can get it to my dealer for the top repair. thanks greatly mike
Reply With Quote
  #5  
Old 03-21-2001, 06:15 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
Mike,

I do not know that much about the ins and outs of the R129 SL (didn't have the time yet to tear down the car), but I never heard of a third fuse box.
My W124 300CE conv. has the additional electrical devices (relays and compu's) under the rear seat, so I can imagine that the R129 has got them under the front seat or rear deck as well (there are some electrical devices under the rear deck).
Does your top react to the switch or is there absolute no reaction at all?? Do you have the hard or soft top on?

The tranny fluid level can be checked with the dip-stick under the hood (check with running engine and tranny shifted in neutral).

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #6  
Old 03-21-2001, 11:20 PM
mike bognar
Guest
 
Posts: n/a
wet sl

thanks again. mercedes in their wisdom has not provided a tranny dipstick. It's called a sealed unit to be checked by the dealer. I have a tranny computer coming and hopefully that will solve the tranny problem. The top switch does not cause any movement in either top and i am only able to use the soft top and manually lock the front down. The roll bar is in the up position and I can not get it to respond to the switch. I can find no blown fuses and was wondering if there are any relays to check? I may have the only route of replacing the top computer which seems to be very prone to failure Thanks again Mike
Reply With Quote
  #7  
Old 03-22-2001, 06:04 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
If the switch doesn't cause a single reaction of the top, it will be an electrical problem (not an hydraulic one). So you are definitely looking in the right direction...

Is it possible to manual control the hard- and soft-top? I managed to close and open the front locks, but that was about all.
The roll bar should respond to the roll bar switch as well as to the top-switch.

Have you checked the connectors at the switches (for power and ground)? Do you have dash illumination in the switches (top and roll bar)?

just some thoughts...greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #8  
Old 03-22-2001, 07:11 PM
mike bognar
Guest
 
Posts: n/a
wet sl

MBENZ thanks again. The switches for the roll bar and the top are both illuminated but get no responce. By jumping the hydraulic system in the trunk it runs but there is no action . It has to be in the control system computer because of the lack of movement. I put a NEW COMPUTER IN THE TRANNY SYSTEM AND IT SEEMS BETTER. Can the systems be read with snap ons scanner Thanks Mike
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
92 500SL differential part number y2kimmel Tech Help 0 09-15-2004 10:34 AM
1990 500sl NO HEAT Rich WNY Tech Help 1 06-25-2004 01:52 AM
500SL exhaust configuration ljmauricio SL Forum 5 02-25-2004 07:44 PM
Avoid what year 500SL? LOWMILE SL Forum 8 10-31-2003 04:42 PM
500SL good years? bad years? spinedoc Tech Help 4 11-04-2002 05:57 PM



All times are GMT -4. The time now is 06:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page