Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2006, 11:59 AM
AChaffier
 
Join Date: May 2006
Location: Oxford, Pa.
Posts: 1
1998 C230 Digital Instrument Cluster Lights

I have a 1998 C230 and the last digit on my digital odometer as well as the last two digits on my digital clock have not been displaying correctly. Most times I have no idea as to the exact time just by looking at the digital clock. My question is, can this be fixed by replacing a bulb or possibly replacing the odometer and clock displays or are all the digital printouts on the console not serviceable as a MB dealer told me and I have to replace the entire console at $1,500??

Reply With Quote
  #2  
Old 05-25-2006, 12:52 PM
GVB GVB is offline
Registered User
 
Join Date: May 2006
Posts: 178
Pretty much a sealed unit. I would try the bulbs though. They are common to go out too. Bummer huh
Reply With Quote
  #3  
Old 05-25-2006, 01:27 PM
forp's Avatar
Registered User
 
Join Date: Jul 2003
Location: Sebastopol, CA
Posts: 324
Quote:
Originally Posted by AChaffier
I have a 1998 C230 and the last digit on my digital odometer as well as the last two digits on my digital clock have not been displaying correctly. Most times I have no idea as to the exact time just by looking at the digital clock. My question is, can this be fixed by replacing a bulb or possibly replacing the odometer and clock displays or are all the digital printouts on the console not serviceable as a MB dealer told me and I have to replace the entire console at $1,500??
Welcome to the forum.
Lots of good information here but you really need to dive in and try to get what you need. I think you'll find that most of the time someone has already been-there, done-that. Use the search function and you'll find you are not the first one to have a problem like this. I think some displays have elements that can be repaired. Hopefully yours is one of them. Also, don't forget to close your thread after you've resolved this so others that follow will benefit from your pai...err-uh, Experiences
Good Luck, Dan
__________________
2012 E350 Bluetech
Reply With Quote
  #4  
Old 05-25-2006, 02:54 PM
BurBenz
 
Join Date: Jan 2006
Location: New Jersey
Posts: 55
Is it some of the elements from "8" missing?
This is not the back bulb problem. It is a display itself loose connections.
LCD display has touch connection with the back board, which sometimes dry joints in result with some element missing or shows some distorted display.
It requires dis-assemble the unit and clean the contact joints.
Reply With Quote
  #5  
Old 05-25-2006, 08:16 PM
Achieving Salvation
 
Join Date: Sep 2002
Location: Madison, Wis.
Posts: 223
You might have to do a little digging, but I remember a post that talked about this (I actually might have started it because I'm having the same problem).

There is a board member who had his cluster pulled, and he sent somewhere in Florida I think, and they worked some magic for $500, and now all is good on the cluster. There may be other places that would do something similar to what this place does, but I remember reading that post awhile back. Good luck in finding it!

-Michael
__________________
+AMDG+
2005 W203
Running as fast as I can to stay behind!!
Reply With Quote
  #6  
Old 05-26-2006, 09:22 PM
Registered User
 
Join Date: May 2006
Posts: 3
Digital Readout

I have a 1998 C230 with the same problem. The digital displays for the odometer, trip odometer and temperature are incomplete and unreadable. I am told that the dealer solution is to replace the entire instrument cluster at a fairly high cost. Another alternative is to pull the cluster and send it to a company in Massachusetts that will repair it for about $300...http://www.bba-reman.com/content.aspx?content=careers_at_bba_reman

The last alternative is what I'm doing right now. I purchased a used cluster for $300 and will attempt to install it myself. http://www.car-part.com/

Good luck!
Reply With Quote
  #7  
Old 05-27-2006, 12:36 PM
Registered User
 
Join Date: Feb 2002
Location: east coast
Posts: 1,255
also chk out this site
www.beckmanntechnologies.com

I've never used them, they advertise in the MBCA magazine

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page