PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   Right side tail lights do not work fuse good (http://www.peachparts.com/shopforum/tech-help/154478-right-side-tail-lights-do-not-work-fuse-good.html)

CDW1998E320 05-28-2006 08:55 PM

Right side tail lights do not work fuse good
 
Any suggestions as to what is wrong? I have checked the bulbs checked all connections and I find nothing wrong, but light do not work.

CDWimberly

sokoloff 05-28-2006 11:20 PM

Common problem. Get someone to step on the brake and wiggle the bulb in the holder. You will ikely find that it works when you move it to certain positions. It tends to lose contact at times. Some replace the entire housing. I have been able to turn the bulb to a position that allows it to work and it holds for a year or more.

Len

h769821 05-29-2006 10:48 AM

I'll second that. My 96-E320 has the same problem that has never been solved by the dealer since new. Every few months, one of the rear brake light or signal light would stop working even if the bulb is still good. Wiggling the bulb or switching bulbs from left to right side make things work again till the next time. It has been like that for 9 years now, never had to replace the bulb itself.


All times are GMT -4. The time now is 03:47 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website