Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-29-2001, 05:25 PM
Bob U
Posts: n/a

We have a 87' 420SEL and the auto transmission has started to shift very rough when shifting from 1st to second and less rough shifting from 2nd to 3rd. It feels the way a manual transmission feels if you "drop" the clutch. The rough shifting is more pronounced when you accelerate slow and not as bad when you give it a little gas. The filter and fluid were changed about 25 k ago. Fluid level is fine, driveshaft, u joints, and rear end are fine. What could be the problem here? Is it a repair, and adjustment, or do I need a new tranny? If I need a new tranny would I be ok to get a rebuilt? And what are the potential costs of all this?
Thanks in advance for any help.

Reply With Quote
Old 03-29-2001, 06:18 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Modulator pressure is adjustable. The 420 and 560s have the additional common fault of the vacuum line to the modulator falling off the vacuum port. The port is hard to see but the line can be seen with the air filter off looking down the backside of the intake manifold. The large vacuum line going to the brake booster starts in this area. There is a banjo fitting and the small port is in that area. Look for the white plastic line passing under the crossover exhaust pipe. That is the line to the modulator. Be sure it is plugged in.

BTW the complete symptom package is a rough idle (vacuum leak) with harsh shifting.
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 03-30-2001, 12:19 PM
Bob U
Posts: n/a
Steve, you nailed it!!

It was just as you suspected. The vacuum line was disconnected. Thanks!!!!!!!!!!!!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'89 420SEL Transmission: Replace or Rebuild? goldstone Tech Help 6 05-10-2005 01:43 PM
420SEL Transmission Shift Points? braverichard Tech Help 4 11-21-2004 08:44 PM
Transmission Woes in Connecticut fatcat Diesel Discussion 25 10-12-2003 07:48 AM
99 S320 Transmission noise BENZ TEK Tech Help 0 06-10-2003 10:32 PM
Transmission Dip Stick - '86' 420SEL maustin Tech Help 4 07-01-2001 08:54 PM

All times are GMT -4. The time now is 07:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page