Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-05-2006, 05:15 AM
Registered User
 
Join Date: Jul 2006
Location: wisconsin
Posts: 100
low transmission fluid

Hi just wrote a couple of days ago regarding my 98 ML 320 ETS/ABS lights remaining on.

Just today a thought came to mind; In December of 2004 I was in a minor accident(slid off the road causing the front clip to be repaired, radiator replaced and some other cosmetics) When I got the suv back it had a slight leak at the tranny coolant lines and after adamantly telling the body shop to check the lines, they've tightened them on two occasions, and no leaks to this day.

I've noticed last summer on really warm/hot traveling days the ETS/ABS light would come on, but then would go off the next time i'd start the suv. By some chance could low tranny fluid cause these lights to go on? Searching for clues!!

This vehicle is amazing, i've done research on several domestic suvs before buying this the MB, and the others can't hold a candle to it. The safety, economy, durablity and practicality keep me sold. I don't want to be let down.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page