PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   C280 Overheating issue (http://www.peachparts.com/shopforum/tech-help/158429-c280-overheating-issue.html)

95-280 guy 07-13-2006 01:23 PM

C280 Overheating issue
 
Having an issue with my 1995 C280 overheating. Typically runs in the range of 80-90C and recently, although the weather has not been above 80F, the car has been moving towards 105-110, up to 115C when its idling in traffic, or even parked with the air conditioning on. Took it to the dealer and they replaced the fan as well as the thermostat.. and the problem continues to exist. Can someone help diagnose what this might be?

david s poole 07-13-2006 02:21 PM

c280-overheat
 
if your system is full of water[coolant]if your fan clutch is good and if your aux fans are working the problem is shrunken aluminum tubes in radiator.it needs replacing. david poole e.p. dallas tx.

gmercoleza 07-13-2006 02:55 PM

If everything else checks out OK, you may just need a new radiator. I once had a car that, despite good H2O pump, hoses, correct coolant mixture, etc. it always ran a little hot. It used to be very stressful watching the temp needle in stop-and-go traffic with the A/C on as the car was always on the verge of overheating. At one point the radiator sprung a leak and I had to replace it. From that point on, the car always ran on the cool side, even on a 90 degree day with A/C on high, parked and idling for an hour.

Before discarding the old radiator, I took a good look at it. The fins were loaded with bugs, though not too bad. There was some corrosion, but with the exception of the area that leaked, again it looked pretty good. Inside there was lots of grit, probably from the PO not flushing coolant as often as needed (if ever). I'm guessing all of the above just combined to reduce thermal efficiency significantly enough. Bugs cut down airflow, corrosion and grit inside might have cut down H2O flow through a few of the tubes, at least enough to make a difference.

Arthur Dalton 07-13-2006 04:15 PM

First check is aux fans.
Pull connector off blue sensor at thermo housing and see if fan comes on to High speed.. if not, check fuse on top of High Fan relay behind fuse box.
If it does come on , then check resistance of aux fan sensor.
Low fan is checked by jumping high pressure switch at reciever/drier ..if low fan does not come on when sw. is jumpered , check fuse on top of Low Fan relay.. if blown, replace 15 A with 25, as this is a Benz up-grade.
If it does come on w/jumper, then the high pressure sw is not working or the a/c system does not have enough refrigerant to get high side to cut-in pressure spec for fan .
Report findings.

95-280 guy 07-20-2006 10:48 AM

overheating 05 c280
 
I picked up the car for the fourth time from Mercedes service after they took it to have the radiator cleaned, replaced the radiator cap (and had done the fan clutch as well as the themostat).. they tell me the aux fan is working. 10 minutes after leaving as I am sitting in traffic the car goes back to 110C. I was in disbelief.. I even called the radiator shop that Mercedes took the car to- he verified they cleaned the system and there was no build-up on the radiator afterwards- did not recommend replacing as they could see no blockage. The car is back at Mercedes as the service manager wanted to have "another look at it".. I see no point as they can't seem to fix it but curious as to how to get this taken care of. Any ideas?

benzfan 07-20-2006 11:06 AM

Have them look for signs of head gasket failure. It was common on the M104 and will cause the overheating you mention.

95-280 guy 07-20-2006 11:19 AM

I will have them take a look at the head gasket although at this point I don't think I would trust their opinion as they haven't been able to accurately diagnose the problem and gave me the car back three times telling me its fine.

benzfan 07-20-2006 12:55 PM

Quote:

Originally Posted by 95-280 guy
I will have them take a look at the head gasket although at this point I don't think I would trust their opinion as they haven't been able to accurately diagnose the problem and gave me the car back three times telling me its fine.

Take it to an independant for the diagnosis of this. The dealership would love another shot-in-the-dark repair try at this point. It's a relatively easy diagnosis, involving coolant testing, oil testing and coolant pressure leakdown testing. You can look for evidence at the back of the engine on the exhaust side. Is there traces of oil at the head/block joint?

95-280 guy 07-20-2006 02:36 PM

That is my plan. The dealership has it but they know I am not going to pay for another item, which is why they replaced the radiator cap and had the radiator cleaned without any charge. At this point I know they don't want to ever see the car again.

In answer to your question- there is no traces of oil and the head/block joint. The area was actually checked over last year by an independent who I instructed to check it over as Mercedes told me I had a head gasket leak... turned out there was no leak (or none that he could find). Supposing I had this issue, would the car only overheat when I am in idle and then return to normal temps when driving faster?

benzfan 07-20-2006 04:58 PM

It's quite possible with a minor leak. I had that with an old BMW 733 I owned over 20 years ago. I finally figured it out when it got so bad that the coolant system wouldn't pressurize. At that point it was all leaking into the engine. Before that, everything tested fine (pressure-wise, nobody did the oil and coolant tests), but the temperature ran up and down.

95-280 guy 07-20-2006 05:19 PM

Thanks Benzfan.. when I get it back from the dealer (eventually they will give up), I will take it to an independent and have it checked. Hoping its an aux fan or radiator issue at this time but still have no clue.

hermanto 08-02-2006 05:03 PM

C220 Overheat
 
C220, 1995
I have similar case, it always over heat during idle/ traffic, it reach 100C+, with A/C on. On Freeway it run o.k 80-85 C.
I notice Aux fan is just running 5 second and off.
Flush new MB coolant done, New Water pump.
How to fix this ?
Please advise, thanks.

dpetryk 08-02-2006 07:41 PM

I have a 86 300e that had all of these symptoms. It turned out that the radiator core tubes were plugging up. These tubes are very narrow and they have an aluminum strip running down the middle acting as a turbulator. Its purpose is to cause the water flow to be turbulent which makes it loose heat more quickly. You cannot even stick a round toothpick through these tubes when they are clean. They are very very narrow. You cannot even see through them when they are clean. As they plug up the flow is reduced and you effectively have a smaller radiator. These radiators cannot be cleaned or rodded out. I tried to have that done. Nobody would do it for the reasons previously mentioned. If the tube is blocked, no cleaner will cure it. If you want to confirm that water flow is reduced or non-existant just put your hand on the radiator and feel for cooler areas while the engine is running. This is where there is low or no water flowing from plugged tubes. The radiator should be equally hot over the entire surface. If its not - its plugged. I know this is almost impossible to do but I did it and then I disected the radiator and confirmed that it had about 1/2 of the tubes were blocked.

An almost 100% guarenteed solution is to replace the radiator and the fan clutch. If everything else is Ok that should fix it.

krisdjsteel 10-31-2009 07:44 AM

94 C280 overheating
 
I'm having the same overheating issue I bought the car 4 days ago off Craigslist from a guy who seemed honest. I told him I bought the car simply to drive back and forth from Arizona to Las Vegas and it needed to be very reliable. I chose this car because I had a 97 E420 and the car it was the most reliable car I ever owned plus I loved it for the same reasons you all do. I drove the car around for 2 days no problems then Thursday morning drove to vegas ran perfect till I came back this morning and got stuck in traffic on the hover dam check point. then again back in town during rush hour and construction. The info here seems very helpful I'm taking it to a shop tomorrow and now know what to expect. My question is How much should these different things cost? Replacement of thermostat fans head gasket replacement etc. Thx again for your help

lalaughery 06-25-2015 12:46 PM

98 C280 temp Gauge
 
My gauge is always on 80 or 81 no matter what I do. When I turn on the A/C it slowly creeps up to 85. I get nervous so I turn it of and the temp drops back to 80. Would a coolant flush help? I am going in for an Oil Change today at Grease Monkey and they do these. Will Grease Monkey be able to check my transmission level since it is not like other cars when checking tranny fluid?

How will I know when I need my breaks checked?

Dumb questions but I am a female and I just bought this car a year ago and drive it maybe 4 times a week for 10 miles. I put synthetic oil in when I bought the car for 2,000 with 164.000 miles.


All times are GMT -4. The time now is 02:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website