Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-2001, 06:16 PM
Larry R
 
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
I have a problem with my 1984 190E. Twice in the past my dash lights have quit working, but came back on. I removed the panel to repair the speedo and the dash lights now wont work. I have rechecked all the wires but they still don't work. The rheostat does work with the heater controls and the transmission. Any ideas where to start. I did a check on the forum but couldn't find this problem. Help!!


Larry
Reply With Quote
  #2  
Old 04-02-2001, 07:31 PM
Registered User
 
Join Date: Mar 2001
Posts: 40
How about your radio light, your blower speed switch light are they still work? If none of them are working at all then it could be the fuse. It could be that you have some burned out light bulbs???

Alex
Reply With Quote
  #3  
Old 04-02-2001, 07:34 PM
Larry R
 
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
I replaced the fuse, and all the other lights work. Just the dash lights don't work. This has happened before. Then they just started working.

Thanks
Reply With Quote
  #4  
Old 04-02-2001, 08:02 PM
Registered User
 
Join Date: Mar 2001
Posts: 40
TRy give it some taping on the instrument face or perhaps some knocking. It may come alive again. If not change the light bulbs.

86 190e 2.3-16
Reply With Quote
  #5  
Old 04-02-2001, 09:19 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
Did you renew the bulbs when you had the dash cluster out of the dash, or did you put it back in with the same (already worn) light bulbs?

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #6  
Old 04-02-2001, 09:32 PM
Larry R
 
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
No I didn't put new bulbs in. It was working fine prior to me pulling the panel out.

Thanks
Larry
Reply With Quote
  #7  
Old 04-02-2001, 09:41 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
It is common for dash cluster bulbs to stop working after the dash cluster has been out of the dash. Renew the bulbs and you will have proper lighting again.
The newer dash clusters start with one bulb not functioning and after the dash cluster has been out of the dash and that worn bulb is renewed, the other three bulbs normally stop functioning at instant.

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #8  
Old 04-02-2001, 10:35 PM
Larry R
 
Join Date: Feb 2001
Location: Oklahoma
Posts: 20
Thanks will do.

Larry
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just "Renewed" the instrument panel, lights and gauges and odometer Eric Eliel Diesel Discussion 21 01-06-2012 01:17 AM
Instrument lights still dead; rheostat bypassed The Warden Diesel Discussion 13 04-08-2005 12:43 PM
Instrument lights dead The Warden Diesel Discussion 2 12-11-2004 11:18 AM
'92 300 E - No Instrument Cluster Warning Lights at Startup jgl1 Tech Help 1 06-27-2002 10:42 AM
Instrument Panel Lights - This Worked jcd Diesel Discussion 1 10-22-2001 12:47 PM



All times are GMT -4. The time now is 07:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page