Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-03-2001, 07:23 PM
Posts: n/a
I have a 1988 420SEL. When I was removing the cruise amp the 14 pin plug pulled apart. Can anyone tell me what color wire goes to which number termial so I can reassemble the plug.

Reply With Quote
Old 04-03-2001, 08:30 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I don't keep this information in front of me at home. Sorry.

You can purchase a CD repair manual in partsshop for future use. It has all of the wiring in it.
Donnie Drummonds
Reply With Quote
Old 04-03-2001, 08:39 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
I keep this information at home! MB gave all us roadside techs a full set of those discs. What the heck do I need 'em at the shop for, we got everything already! Oh, they put 'em in a real official looking CD-ROM case, too! OK, here we go: Socket 1 is Black with a pink stripe, Socket 2 is Yellow with a green stripe, Socket 3 is Grey, Socket 4 is Green, Socket 5 is White, Socket 6 is Blue with a red stripe, Socket 7 is Black, Socket 8 is Black with a red stripe, Socket 9 is Violet, Socket 10 is Blue, Socket 11 is Green with a black stripe, Socket 12 is 2 Brown wires, Socket 13 is Yellow, and Socket 14 is vacant (no wire)......Gilly
Reply With Quote
Old 04-04-2001, 08:21 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
On the 1988 420SEL's the # 14 pin can have a brown wire if the cruise computer is the analog version, no wire if it's the later digital version with coding plug~!
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 04-04-2001, 08:15 PM
Posts: n/a
Thanks Everyone for the help, mine had the 14th brown wire. I have the plug back together and have resoldered the amp. I just came in from a test drive and the cruise is working 100%
Reply With Quote
Old 04-04-2001, 10:43 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
MB Doc: Yeah, that's what gets me every time I gotta replace an amp with the new style with coding plug, gotta cut that wire, there's an SI about it, man that's an old SI. I never new about this analog vs digital stuff. I thought the whole reasoning behind the coding plug was that MB could sell the same amp for lots of cars, but have different coding plugs, which represented the chassis/engine combinations. Anyways, that's what the teamleader says, he's been a MB tech since our dealership got the franchise for MB in '72. What's the deal with calling the cruise module an "amp" anyways? I figure MB thinks they'll get sued for causing people to turn into stutterers by saying "cruise control control module", especially mechanics and parts guys. SIX TIME Master Guild!? Holy Crap, that's alot of German beer! I got Master Guild last year (2000), first year I was elgible due to not being able to go to training for the first 3 years I was working on MB's (long story). I'm waiting to see how the new TRP will turn out, ain't had a training date since it started. Wondering if they'll even still have a pewter model for Master and Master Guild. The pewter model I got for Master is the "last" one, last serial number, so it would really be something if they don't do the pewter models again. This whole new thing they're doing this year, I just don't know how that's going to work out, we'll see, I guess. Wonder if you got Master or Master Guild in 93, I think it was, the year they used the 300SL Gullwing for the pewter model, THAT would have been a good year to make Master.......Gilly
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Repair Greg in Oz Tech Help 0 02-29-2004 06:25 PM
82 300SD throttle linkage and cruise control waybomb Diesel Discussion 0 12-28-2002 05:52 PM
Cruise Control Supposedly never worked right on my car...???? 190D22 Diesel Discussion 7 12-28-2002 04:13 PM
1994 C-220 Idle Problem and Wiring Problems Bill Driver Tech Help 1 11-11-2002 10:06 AM
My $2.68 Cruise Control Fix...Search Function Saved $$$ Lance Allison Tech Help 0 09-18-2001 07:12 AM

All times are GMT -4. The time now is 02:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page