Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2006, 04:54 PM
Registered User
 
Join Date: Jul 2006
Posts: 6
Unhappy ets/abs 95 s320

hi, i have a 1995 s320 in the shop. it has abs and ets lights are on. i am using a modis with german software. i am unable to retrieve codes. knowing what i know i did replace brake light switch. this did not make a difference. the light comes on sometimes when you crank the wheel. always when turning the wheel to the right about 3/4 of the way to stop. this can be with vehicle sitting still. the left front tire is of different brand, but same sizes. the right rear was underinflated about 10 lbs corrected - no difference. battery charged to 14.5 volts. we replaced the wiring harness about 6,000 miles ago, when we did valve job on engine. any help will be appreciated.
thanks,
marie

Reply With Quote
  #2  
Old 08-09-2006, 06:18 PM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
abs/ets

marie,did you use a genuine brake light switch from the dealer? the aftermarket ones are junk been caught twice myself. david poole european performance dallas tx.
Reply With Quote
  #3  
Old 08-09-2006, 08:29 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Try lock to lock a couple of times to reset the steering angle.
Reply With Quote
  #4  
Old 08-10-2006, 12:26 PM
Registered User
 
Join Date: Jul 2006
Posts: 6
ets/abs

Hi, update, I did use an aftermarket brake light switch from gap in atlanta, i got an oem one this a.m. it made no difference. not throwing up any codes in modis. took car to dealership to scan, they cannot get any codes from it. the cruise does not work when the light is on. can i disconnect the steering switch on gear box to bypass? the mb technician recommended to replace the unit in the right control box (the one that holds two fuses.) i hate throwing parts at cars...............

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page