Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-11-2006, 05:45 PM
Registered User
 
Join Date: Aug 2006
Location: hollywood FL
Posts: 6
excessive smoke no power

I have a 300sd that will not accelerate with lots of smoke. this problem came on suddenly. fue.l filters have been changed.this seemed to happen after I changed the air filter and took the housing off to clean it any ideas as to what got screwed up?the color of the smoke is black. no, nothing went in the intake since it is sideways to accept the tubo intake hose. I also adjusted the valves.I wonder if the EGR could be sour? any ideas?


Last edited by stoppro; 08-12-2006 at 05:59 PM. Reason: more info
Reply With Quote
  #2  
Old 08-12-2006, 02:25 AM
diametricalbenz's Avatar
The Crowbar of Embriage
 
Join Date: Oct 2004
Location: Milwaukee, WI
Posts: 3,510
What color is the smoke? Did something fall into the intake when you changed the air filter?

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page