Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-13-2006, 02:30 AM
Registered User
 
Join Date: Mar 2006
Posts: 78
Turn Signals all stopped working

All of my turn signals, both front and rear have stopped working. It was wondering fine the day before and then suddenly they stopped working. I checked all the fuses but they are all intact and working. What could be the problem?

Reply With Quote
  #2  
Old 08-13-2006, 06:57 AM
Registered User
 
Join Date: Jul 2003
Location: Ocean Isle Beach, NC
Posts: 2,463
What car? On the 123 chassis sometimes the hazard switch gets stuck in between on and off and this causes the turn signals not to work. Try turning the hazard lights on and off a few times.

Len
Reply With Quote
  #3  
Old 08-13-2006, 10:51 AM
Smokiesman's Avatar
Bryson City NC
 
Join Date: Mar 2005
Posts: 182
On my 95 E420 the relay that runs I believe the wipers also had something to do with the turn signals! Relay was not making good contact! If I pushed down of the relay it worked! I juryrigged a block made of cardboard for the top of the relay and when the cover was snapped down it pushed the relay down! Been working over 2yrs. now!


Smokie
__________________
95 E420 BigBlue
500E Sway bars
2001 C Class 16 in. Rims
KYB Struts and shocks
Rear spoiler
American Stitches Wheel
Bigred 99 F250 Powerstroke
JVC EXAD Mp3 player
JVC EXAD GPS


Reply With Quote
  #4  
Old 08-14-2006, 09:30 AM
Monomer's Avatar
Colonel Blitz
 
Join Date: Jan 2006
Location: Detroit, MI
Posts: 836
If it's a w126, check the relay under the steering wheel.


A shoot of contact cleaner and mine started to work perfectly. (only after cleaning the hazard, replacing old fuses, etc...)

__________________
-1983 VW Rabbit LS Diesel (5speed, VNT/Giles build)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page