Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-11-2001, 07:32 PM
Posts: n/a
I was called on a 1966 250-SE, it is a no start. This Vehicle is Fuel injected. Can anyone tell me fuel pressure, and also Injector pluse requirement, also maybe point set/gap. I have no info on this car. Thank you for any help.

[Edited by Carphd! on 04-12-2001 at 07:27 PM]
Reply With Quote
Old 04-12-2001, 05:57 PM
cth350's Avatar
Registered User
Join Date: Dec 2000
Location: Long Island, NY
Posts: 3,651
I assume you mean a 1966 250SE... [If you had another car in mind, let me know]

Quoting the 1966 TDM...

- With the engine not running and the battery reading atleast 11v, the pressure down stream of the filter should be 0.8 to 1.1 kg/cm-squared (which is 14.88 lbs/square-inch).

- At the overflow valve of the injection pump, the pressure should be AT LEAST 1.3 kg/cm-squared.

- Fuel should be delivered at that same point at a rate of AT LEAST 3 liters/minute.

- The point gap should be 0.3-0.4mm, resulting in a dwell of 37-41 degrees. For new points aim for the 41 figure. Also test dwell at idle and 4000rpm. If there is a deviation of greater than 3 degrees, rebuild the distributor.

There is a great writeup of mechanical fuel injected systems

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
What may be wrong if a 1981 Mercedes 240D can only start when doing a push start? ericnguyen Diesel Discussion 5 03-26-2003 10:40 AM
1972 250 - Cold start and acceleration problems rgnprof Vintage Mercedes 66 03-18-2003 05:36 AM
Mercedes 240D only starts if I "push" start it. ericnguyen Tech Help 4 03-08-2003 05:49 PM
260E has sparks but will not start saumil Tech Help 3 08-17-2001 02:29 PM
1991 420SEL - beginning of a cold start problem DieselGuy Tech Help 1 07-30-2001 03:56 AM

All times are GMT -4. The time now is 05:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page