Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-05-2006, 01:40 PM
Registered User
 
Join Date: Sep 2006
Location: Whittier, Ca
Posts: 6
Unhappy What to do with a rough idle?

I recently got a 79' 450 SEL that some guy left at my mechanics shop and after telling him to get it running and then decided that he didn't want it.
Anyways it's timing is supposed to be at TDC but it's at 15 and when I put it at TDC it just about stalls out completely. Even when it's at 15 it will run ok and then it will run really rough every few secounds, kinda like it's going to stall out. I have changed the tranmission fluid and filter, oil and filter, new spark plugs and wires, check the fuel injectors and changed the one that seemed to need to be changed, and redid all the vacumm hoses put them where they are suppose to be, a new radiator, fuel pressure damper, warm-up regulator, fuel filter. It drives pretty good once it gets up to speed it doesn't have alot of power right off, which it should, and the rough idle kinda gets worse in reverse. When I first drove it home it didn't backfire and now after all this work now it does. Also when the mechanic was working on it he took it to get smogged and it wouldn't pass, "couldn't adjust low enough to pass".

I don't understand and don't know what to do does any one out there know I would appreciate all the help I can get.
Thanks
Reply With Quote
  #2  
Old 09-05-2006, 04:37 PM
Battlecat714's Avatar
NEEZ FTW!
 
Join Date: Apr 2006
Location: Anaheim, CA
Posts: 339
Quote:
Originally Posted by MercedesGirl View Post
I recently got a 79' 450 SEL that some guy left at my mechanics shop and after telling him to get it running and then decided that he didn't want it.
Anyways it's timing is supposed to be at TDC but it's at 15 and when I put it at TDC it just about stalls out completely. Even when it's at 15 it will run ok and then it will run really rough every few secounds, kinda like it's going to stall out. I have changed the tranmission fluid and filter, oil and filter, new spark plugs and wires, check the fuel injectors and changed the one that seemed to need to be changed, and redid all the vacumm hoses put them where they are suppose to be, a new radiator, fuel pressure damper, warm-up regulator, fuel filter. It drives pretty good once it gets up to speed it doesn't have alot of power right off, which it should, and the rough idle kinda gets worse in reverse. When I first drove it home it didn't backfire and now after all this work now it does. Also when the mechanic was working on it he took it to get smogged and it wouldn't pass, "couldn't adjust low enough to pass".

I don't understand and don't know what to do does any one out there know I would appreciate all the help I can get.
Thanks
motor mounts?
__________________
1994|040|W124.036|E500
http://www.mbworld.org/forums/image....ine=1216527951
Reply With Quote
  #3  
Old 09-05-2006, 06:11 PM
Registered User
 
Join Date: Sep 2006
Location: Whittier, Ca
Posts: 6
Nope not the motor mounts.
Reply With Quote
  #4  
Old 12-18-2006, 11:20 PM
Registered User
 
Join Date: Nov 2004
Location: Dallas, TX
Posts: 4,969
figure it out

Did you ever figure it out?
__________________
With best regards

Al

Check out the W114, W115 enthusiast website.
http://www.stroke8.org

http://www.w108.org

Join the Mercedes W108 group
http://autos.groups.yahoo.com/group/mercedesw108/

My 280SL restoration

http://www.w108.org/gallery/albums/a...0959.thumb.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page