Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-06-2006, 10:06 PM
Registered User
 
Join Date: Feb 2003
Location: rural chicagoland
Posts: 165
95 S 320 ac woes

Howdy folks:

I have a 95 S320 with some AC issues - I am aware this is common

sometimes when the air is on - the defroster will engage and blow hot air thru at same time - rather uncomfortable as we are still in the desert summer.

I am preparing to take apart the dash and ( attempt ) to remedy this - will like to gather as much info as possible here before I attempt the impossible- I did some searches - not sure but think I saw info before - just cant get to it now

Cheers thanks y'all

thanks in advance

__________________
nibiru
82 300TD- diggin it
Ich habe Dinge gesehen, die ihr Menchen niemal glauben würdet
Gigantische Schiffe, die brannten, draußen vor der Schulter des Orion
Und ich habe C-beams gesehen, glizernd im Dunkel, nahe dem Thannhäuser-Tor
All diese Momente werden verloren sein....in der Zeit
so wie...Tränen im Regen
Reply With Quote
  #2  
Old 09-06-2006, 10:24 PM
Registered User
 
Join Date: Sep 2004
Location: DFW / Collin County Texas
Posts: 1,882
Disassembly of the dash on the W140 is no easy task. Why do you feel you need to disassemble? Did you catch a hit of UV dye in the condensate drippings? Is it a matter of losing refrigerant or do you suspect that pneumatic blend flaps are not working?

I would check the operation of your heater valve(s) first. Use clamps to interrupt coolant flow and rule that sucker out.
__________________
08 W251 R350
97 W210 E320
91 W124 300E
86 W126 560SEL
85 W126 380SE Silver
85 W126 380SE Cranberry
79 W123 250
78 W123 280E
75 W114 280
Reply With Quote
  #3  
Old 09-06-2006, 11:53 PM
Registered User
 
Join Date: Feb 2003
Location: rural chicagoland
Posts: 165
howdy GMercoleza:

Thanks for the reply:

my concern is the flaps or dashpot/ vacuum controls are the culprit

as the air will still blow cold yet the out of the center vents but the defroster will blow HOT- sometime the heat comes from the side vents

cheers thanks
__________________
nibiru
82 300TD- diggin it
Ich habe Dinge gesehen, die ihr Menchen niemal glauben würdet
Gigantische Schiffe, die brannten, draußen vor der Schulter des Orion
Und ich habe C-beams gesehen, glizernd im Dunkel, nahe dem Thannhäuser-Tor
All diese Momente werden verloren sein....in der Zeit
so wie...Tränen im Regen
Reply With Quote
  #4  
Old 09-07-2006, 12:27 AM
Registered User
 
Join Date: Sep 2004
Location: DFW / Collin County Texas
Posts: 1,882
Check the heater valve - do a search here either on monovalve or duovalve (I don't know which one you have). With the symptoms you describe there is a strong possibility this valve is bad. There should not be any heat coming out of the vents even if the flap is bad, since the valve shuts off coolant flow to the heater core when activated. I know on the W210 chassis the first sign of a failing valve is hot air out both side vents (versus hot air on just one side which is a sign of refrigeration problems). Like I said, you can try clamping the heater hose around the valve to see if this stops the hot air from blowing - if it does, you have narrowed down the cause of it.

Believe me, you'll be in deep if you start tearing that dash apart. I would do that as a last resort...

Do a search is all I can tell you.
__________________
08 W251 R350
97 W210 E320
91 W124 300E
86 W126 560SEL
85 W126 380SE Silver
85 W126 380SE Cranberry
79 W123 250
78 W123 280E
75 W114 280
Reply With Quote
  #5  
Old 09-07-2006, 12:48 AM
Registered User
 
Join Date: Feb 2003
Location: rural chicagoland
Posts: 165
howdy again gmercoleza:

I was hoping to come across someone who could direct to me to a good write up or previous discussion on this matter

i have read on other sites "I think" of how some have sold their W140's instead of fix this problem- I have done searches and will continue - and will try your suggestions as well

Cheers again

__________________
nibiru
82 300TD- diggin it
Ich habe Dinge gesehen, die ihr Menchen niemal glauben würdet
Gigantische Schiffe, die brannten, draußen vor der Schulter des Orion
Und ich habe C-beams gesehen, glizernd im Dunkel, nahe dem Thannhäuser-Tor
All diese Momente werden verloren sein....in der Zeit
so wie...Tränen im Regen
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page