Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-17-2001, 12:15 AM
mgreenhouse
Guest
 
Posts: n/a
Recently my wife's teal green benz (300sel) would not start.
Engine would not crank over..Has a new 750amp Interstate battery ( the good one) . Check the voltage at the battery and is a constant 13.6 volts.. no change with the engine rev up or underload..Need to know if I need an alternator or just a voltage regulator..???
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excellent Diesel Article Ron Johnstone Diesel Discussion 7 02-18-2005 04:18 PM
Issues to look for on a 1990 300SEL with 204k miles? 123c Tech Help 3 11-14-2004 08:22 PM
1988 300SEL question Snibble Tech Help 16 09-27-2004 05:08 PM
nice 1969 300SEL 6.3 for sale, Portland OR gerryvz Mercedes Cars For Sale 0 06-23-2003 07:09 AM
Forsale: 1979 300SD Excellent 129k miles $5500 79mb300sd Mercedes Cars For Sale 2 12-13-2002 10:50 PM



All times are GMT -4. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page