Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-17-2001, 06:56 PM
Joe VB
Posts: n/a
My 1990 300SE has started to feel "jiggly" and "spingy" when going over bumps. It also seems noisier when going over bumps. Does it need shocks? It passes the "rock the front end up and down" test as it stops bouncing in 1-2 bounces. Thanks!
Reply With Quote
Old 04-17-2001, 07:02 PM
oldsouth's Avatar
Registered User
Join Date: Feb 2001
Posts: 610
Check the front suspension parts for wear.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W126 Lessons Learned on R&R Front and Rear Shocks stephenson Tech Help 7 12-22-2008 09:09 PM
300TD gets new front shocks Richard Eldridge Diesel Discussion 0 07-01-2004 10:21 AM
W126 going with H&R springs, what shocks? David Henneman Performance Paddock 3 10-26-2003 01:17 AM
Ride height question / New shocks on a 1991 190E 2.6 (154k miles) brookspw Tech Help 18 08-10-2003 04:18 PM
New shocks at last Richard Eldridge Tech Help 5 04-16-2002 08:44 AM

All times are GMT -4. The time now is 05:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page