Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-18-2001, 01:11 PM
Posts: n/a
Yesterday my climate control lights began working after never working since i bought my 83 300D a year ago. The little buggers even brighten up when they are depressed, i was thrilled. However the temp control and hi/low sides dont work, or do these light up. Since my middle part lights up, is it just that the fiber optic cables arent hooked up to the sides? How easy can this be done? I will look in the Haynes manual, but not sure still.
Reply With Quote
Old 04-19-2001, 04:36 PM
MBenzNL's Avatar
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
The European (non-airco) W123 heater systems have separate bulbs for the complete heater control panel and have one central bulb (behind the front plate of the console) for the fiber optic cables that run to the different switches (push-only) on the console.
None of the lights on a euro W123 are hard to replace.

1990 300SL-24
1993 C250D
with a minor 600+k kilometer
(the Netherlands)
Reply With Quote
Old 04-19-2001, 06:31 PM
Posts: n/a
My climate control lights will fade and eventually extinguish after a few hours of driving. They come back on if I turn the lights off and and restart the car.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 SLK 230 brake lights not working - not bulbs or fuse MBZ OE Tech Help 5 02-24-2005 06:03 PM
96 c220 won't start mcollie Tech Help 3 11-07-2002 04:15 PM
Euro Headlights DZLPWR Diesel Discussion 10 10-07-2001 12:03 PM
Quick Cibie question....... DieselHead Diesel Discussion 3 09-21-2001 04:38 PM
Help - Is this a coincident? - Instr. cluster lights not working. tony s Tech Help 3 05-07-2001 10:23 PM

All times are GMT -4. The time now is 03:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page