Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2001, 05:48 PM
MGL
Guest
 
Posts: n/a
i just put new pads on the front the front driver side anti lock is activating at slow speeds on any surface and it is also squelling and the front passenger side is fine, all was well until i put the new pads on any ideas
Reply With Quote
  #2  
Old 04-19-2001, 05:51 PM
MBenzNL's Avatar
MBenzNL
 
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417
You better take off the wheel again and have a look at what went wrong...Is it possible that you inserted one of the pads inside out?

greetingz,
__________________
1990 300SL-24
1993 C250D
with a minor 600+k kilometer
www.MBenzNL.com
(the Netherlands)
Reply With Quote
  #3  
Old 04-19-2001, 06:34 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Early ABS sensors on cars like yours fail often & allow ABS to activate out of normal range. The replacement sensors have modified *STRESS* reliefs.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #4  
Old 04-19-2001, 08:13 PM
MGL
Guest
 
Posts: n/a
there not on backwards i took them off and switched the outside to the onside because they are both the same it went away for a while and now its back again could it be that the pads are defective
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'90 300e 4matic front (brake) grinding Dave Payntar Tech Help 2 01-25-2003 01:52 AM
300E springs and brake rotor/pad combos lizem100 Tech Help 7 01-07-2003 12:40 PM
1988 300e front seat springs asiamood Tech Help 1 11-04-2002 01:41 AM
help please, dash brake light blinking -- 300E pmizell Tech Help 13 12-07-2001 10:54 PM
ML320 front brake pads herbert ML, GL, G-Wagen, R-Class, Unimog, Sprinter 6 01-08-2001 11:42 PM



All times are GMT -4. The time now is 02:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page