Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-20-2001, 01:43 PM
Posts: n/a
I have a problem with the tach in my '82 300D. It fluctuates between 0 (most of the time) to 5000 rpm even when at idle. I also notice that when I turn the key to "on" before I crank the engine, it fluctuates as well. I tried the "cigarette butt" trick on the sender and even replaced it with another one but it is still erratic. It sounds like some sort of electrical problem. I don't know how the tach circuitry is wired. Any suggestions?
Reply With Quote
Old 04-20-2001, 10:37 PM
Posts: n/a
Dear mb300d,If you've already replaced the sending unit,the only other thing left is the wiring. I would check the power to the gauge itself, by pulling out the cluster and using either a volt meter, or a test light to ensure you have juice. After that, maybe disconnect the wire that runs to the sending unit, and temporarilly run a jumper wire, outside and seperate from the car's wiring harness. If the tach works now, you'll know that the factory wire is no good.
Reply With Quote
Old 04-21-2001, 04:48 AM
longston's Avatar
Another View. . .
Join Date: Dec 2000
Location: Mark West, CA
Posts: 787
Three Parts To The Circuit...

There's the TDC sensor in the motor, the TDC sender on the fender well, and the tach itself. Along with the wiring to connect it together, the problem could be anywhere.

If you've replaced the sender with a new one, I would try giving it some time to adjust. Sometimes these things seem to fix themselves...

My next suggestion would be the tach itself, and then the sender in the motor. Good luck, and let us know what works!
"We drive into the future using only our rearview mirror."
- Marshall McLuhan -

Scott Longston
Northern California Wine Country...
"Turbos whistle, grapes wine..."
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
ECU and Tach on 85 300TD benzzy Diesel Discussion 5 09-24-2004 11:34 AM
Got "new" tach guage, but not working properly rbort Tech Help 0 02-25-2004 11:00 AM
Adding a tach to a 300TD 81Wagon Diesel Discussion 8 01-11-2004 07:05 PM
Tach making AGGRAVATING noise! rwthomas1 Diesel Discussion 3 12-29-2003 09:59 PM
New 300 TD Tach Fix Andrew Fekete Diesel Discussion 10 04-15-2002 02:47 PM

All times are GMT -4. The time now is 03:10 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page