Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-21-2001, 04:20 PM
Registered User
 
Join Date: Mar 2001
Posts: 21
I had an overheating episode with this car when its radiator header top outlet snapped off (corrosion fault).

I stopped the car when I noticed the heat gauge needle was right up --it may have been like that a few minutes at very most--and the car was going well. After a long cool-off and replenished water etc the car started and went quite normally.

Cold start the next morning there was noise we had not had before--like a noisy hydraulic valve lifter. Anyway, with the oil slightly smelling burnt it was changed with a new filter and a can of STP added.

The car is not using water, oil is clean and it runs perfectly.

My problem is that while starting from cold the engine now has noisy metallic clunking for a few turns until oil pressure builds up.

What is this noise typically likely to be?

Any guidance will be very much appreciated.

Thank you

Ed Cumings
Reply With Quote
  #2  
Old 04-21-2001, 10:10 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
That is a tough one. You should let a tech keep it over night and hear the noise.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 04-21-2001, 10:51 PM
Registered User
 
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
You are so lucky that the head didn't warp. Thank the Gods of M103 for that large blessing.
__________________
Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
No matter what you fix, there will always be something else to fix..
"Warranty" is just another way of postponing the inevitable.
Reply With Quote
  #4  
Old 04-22-2001, 01:51 AM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
had a similar episode with my 300E when the neck
of my rad broke. didn't do anything except to
replace the radiator.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How many DIFFERENT 1989 300E alternators? Spo123 Tech Help 2 10-04-2004 11:31 PM
1989 300e stalls when coasting wishingwellman Tech Help 1 04-18-2004 11:37 AM
1989 300e robi99 Mercedes Cars For Sale 1 06-09-2003 11:19 AM
Steering Box Adjustment. 1989 300E William Tobin Tech Help 2 08-11-2002 10:24 AM
Jack for 300e (1989) jeffsr Tech Help 13 01-24-2000 04:23 PM



All times are GMT -4. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page