Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2001, 10:26 AM
Primo
Guest
 
Posts: n/a
Recently purchased my 1st M-B, a 1987 300E with 110K. It has a few problems that I wish to address, and it seems that through this wonderful site I should be able to get the correct info. The cruise control basically doesn't work. I've been able to engage it only 2 times, each time it shut itself off within about 15 seconds. Any ideas?? Is this something I could take care of myself? Thanks!!
Reply With Quote
  #2  
Old 04-29-2001, 12:57 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
 
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
One of the least expensive checks is to go through all the exterior light bulbs and the 3rd brake light bulb and make sure they are all the same brand and wattage, preferably German bulbs. The speed control switches off when your brakes are applied, and if there is evev a tiny 'strange' ohmage on either brake circuit (each circuit shares a brake bulb with other bulbs - look at the info inside the lid of the fuse box)it can affect cruise control operation. This may not be your problem, but is an easy and dirt cheap possible fix.

Also, there was a recall on throttle linkage bushings. If yours wasn't done that could make your linkage difficult for the unit to control, if I recall correctly.

The system has a controller and an amplifier, and I don't recall the order to check them in or replace them if they have a problem. Check the search feature - this has been discussed a lot over the last couple of years. I am sure some of the techs will answer with even better ideas about what is going on. Good luck, and let us know what you find.
__________________
John

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
  #3  
Old 04-29-2001, 02:03 PM
Primo
Guest
 
Posts: n/a
Thanks John! I'll get to work on the light bulb inventory
as soon as I get a free moment. At least it's a place to start.
Reply With Quote
  #4  
Old 05-09-2001, 04:26 PM
Primo
Guest
 
Posts: n/a
John- I replaced all of the light bulbs(OSRAM) on the rear of the car. The cruise control now works! Thanks. It was intesting to note that all of the old bulbs looked rather fried......though they all still worked. All of the elements on the inside of the bulbs looked corroded.
I sure appreciate your "quick fix".

I do have another question. Though the cruise now works, and stays on when engaged, it does seem a little bit hesitant when first turned on. Is this a symptom of another ailment or is this how MB cruise controls work? I guess what I'm talking about would be best described as a slight lag when you first engage the CC.
Reply With Quote
  #5  
Old 05-09-2001, 08:26 PM
benne300
Guest
 
Posts: n/a
Cruise Control

My 1989 was doing the exact same thing. This is my first MB also so I was looking at this grea site for help. My cruise now is rock steady. I fixed it try to fix another problem. All I did was change the Over Voltage Protection Relay and now it works. Not sure if that is your problem but it fixed mines. I'm not even sure what the OVP does to the Cruise control but it worked.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control - Normal Behavior ? DougLL Tech Help 2 06-24-2003 04:02 PM
Cruise Amp On 300E PA_Joe_300E Tech Help 4 12-10-2001 01:24 PM
My $2.68 Cruise Control Fix...Search Function Saved $$$ Lance Allison Tech Help 0 09-18-2001 08:12 AM
Cruise control on '86 300E dacia Tech Help 3 03-15-2000 08:30 PM
86' 300E Cruise control Chris C. Tech Help 1 07-27-1999 08:29 PM



All times are GMT -4. The time now is 06:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page