Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-21-2006, 12:24 PM
Registered User
 
Join Date: Dec 2006
Posts: 3
Unhappy 1997 SL500 129 Climate Control unit

I wonder if anyone can help me with this little problem.

on AUTO it seems that recently the climate control system is on it's own agenda. The temperature setting when on AUTO does not seem to make much of a difference; the fan ramps up and ramps down and blows out warm and cold air as it pleases. I don't think that it is the thermostat as it seems to work on MANUAL setting; although there is a problem here too.

On MANUAL the fan speed can be made to increase and although you can hear the fan working at full speed, very little air comes out of the side/center vents when directed to by the red/green center buttons.

On EC off (A/C on) the air comes blowing out of the center vents enough to make you feel like the dog with it's face out of the window at 60mph!

I have had the car for 5 years and it has always worked really well; I cannot put my finger on it but something is just not right here.

I suspect that it may be the controller unit needing to be reset - I don't know how to pull the codes off and reset them.

ONE CLUE - No matter how many times I press the AUTO button, the little LED on it remains always on, even though the LCD display toggles the "AUTO" indication on and off. This is new.

I have done a visual on all the vacuum lines and, removing the control and radio from the dash, I am able to verify that all the lines behind the dash are good too.

Is there a RESET - type function that can bring this little electronic device back into my SL fold please?

Thanks
Phil

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page