Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-28-2006, 04:18 PM
Registered User
 
Join Date: Dec 2006
Posts: 3
C220 1994 rough idle and no power between 700-1500RPM

I have Benz C220 1994 model. Most times the car runs smoothly although at times at idling the revs keep jumping up between 700-1000. Also at that time if I shift to drive, and step on the brakes, the car feels as though it is about to take off. If I release the brakes the car will shoot off and gain speed. At normal times this would not happen. Also at times between 700-1500RPM the car shudders and has no power. Once it crosses 1500RPM, the car is back to normal. The throttle accuator used to make a clicking noise on ignition and I was adviced to change it. I have changed it and the noise has gone but the problem still lives. Also the wiring harness has been repaired previously. What could the problem be? ALso do I need to take some precautions when changing the accuator?
Help!!!




Last edited by Baiju; 12-29-2006 at 04:02 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page