Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-23-2007, 02:44 PM
Registered User
 
Join Date: Feb 2006
Posts: 38
Oil Pressure

I have a 1988 300SE and the oil pressure gauge works when the pressure is about 1.5 or above but when I am at idle the gauge sits at 0. As the revs drop off it drops off normally but when it gets to about 1.5 on the gauge it falls to 0 in an instant. Is this a faulty gauge or sender? I have compared it to the gauge on my 260E and above 1.5 they act the same. It is almost like the gauge just doesn't read on the low end. Oil pumps either work or they don't right? Sorry if I have confused anyone. Thanks.

Reply With Quote
  #2  
Old 01-23-2007, 04:37 PM
Registered User
 
Join Date: Aug 2006
Location: Houston, TX
Posts: 450
Sounds like a bad sender. You aren't hearing any tick-tick-tick noises from the engine at idle, are you?

The sender is probably the easiest to replace as opposed to the gauge.

On my '92 300se, there's a diagnostic program for the instrument panel that allows you to check the gauges in the 4 quadrants of swing - would be handy if you had a similar test on your earlier model.
Reply With Quote
  #3  
Old 01-23-2007, 09:00 PM
Dr.Bob
 
Join Date: Jan 2007
Location: Petersburg IL
Posts: 10
a quick test to dertimine if gauge works fully is to pull plug from sender unit at oil filter area turn on ignition switch gauge should go to full pressure if gauge works properly replace sender unit
Reply With Quote
  #4  
Old 01-25-2007, 07:40 AM
Registered User
 
Join Date: Feb 2006
Posts: 38
Thanks, I will check it out.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page