Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2007, 03:19 PM
Registered User
 
Join Date: Oct 2002
Location: Texas
Posts: 303
OVP vs FPR ( signs and symptoms) w124 300E

OVP (Over voltage protection)
can restart ?
surges before stall mostly on deceleration?
engine can run(rough) w/o relay plugged?


FPR (fuel pump relay)
No restart?
stall anytime any rpm?
No relay, no run?
If bypassed, will start.
can still hear Fuel Pump preload on ignition on and still have a bad relay?

Am I correct in assuming these symtoms for these components? Please add or change as necessary.

__________________
a2


1978 280 CE silver
1986 560 SL black
1987 300 SDL cream
1994 SL 500 brilliant green
1997 E 300d dessert silver
2005 FORD F250 Superduty Crew cab 4x4

____ADMU____
Reply With Quote
  #2  
Old 01-26-2007, 06:40 PM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
Quote:
Originally Posted by a2aa View Post
OVP (Over voltage protection)
can restart ?
surges before stall mostly on deceleration?
engine can run(rough) w/o relay plugged?


FPR (fuel pump relay)
No restart?
stall anytime any rpm?
No relay, no run?
If bypassed, will start.
can still hear Fuel Pump preload on ignition on and still have a bad relay?

Am I correct in assuming these symtoms for these components? Please add or change as necessary.
OK I've had both so feel qualified to post!

FPR - Only ever heard of it failing to start. Doesn't usually cause cut-out once on the move. Not sure why..
No relay no run, correct
Bypassed will start, yes.
If you hear the fuel pump run when you switch the ignition on, it is fine (on that occasion). Other times you turn ignition on and fuel pump doesn't run. This is the usual intermittent faulty FPR.

OVP - can run without, yes (cold starting sucks, ASD and ABS lights will probably light)
I've run my 2.5-16 without OVP briefly, it doesn't run that badly. Perhaps when cold, or if the weather was really bad it might be worse. But when engine is warmed it seems to run pretty much as normal.

Just my experiences in 5 years of ownership!
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
  #3  
Old 01-29-2007, 10:28 AM
Registered User
 
Join Date: Oct 2002
Location: Texas
Posts: 303
thanks

for verifying these. My other revalation, my 1990 300E has the FPR on MAS computer. SO, my next question is to verify if the fuel pumps are working.

upon switching key to "ON" position and hearing the primary fuel pump "preload" the line, would the secondary pump have current going to it as well? Reason I ask is because if it does, all I need to do is check voltage supply to the 2ndary pump and if it's present, the pump should be humming, vibrating or atleast doing something to tell me it's working as well, correct? If not, then I need to remove it and check it manually on the bench.

It is safe to assume that FPR is working because main pump "preloads" on ON position. And there is only ons FPR that operates both pumps?
__________________
a2


1978 280 CE silver
1986 560 SL black
1987 300 SDL cream
1994 SL 500 brilliant green
1997 E 300d dessert silver
2005 FORD F250 Superduty Crew cab 4x4

____ADMU____
Reply With Quote
  #4  
Old 01-29-2007, 07:17 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,631
when i lost our ovp on the 89 CE, it would briefly start and then stall...wouldn't run.

abs light came on....i think the CEL as well..

fortunately i had a spare in the shop...

i have learned over the years reading these posts that you keep a spare ovp, fuel pump relay and klima relay as well as a voltage regulator in a pouch in the shop or the trunk in your car....

cheap insurance.

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page