Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-31-2007, 06:48 PM
Registered User
 
Join Date: Jan 2007
Location: Fairfax, VA
Posts: 2
Sluggish 1989 300E

We have a 1989 300E which has become a danger to drive! It is VERY sluggish on take off and until the car gets completely warmed up. Once you get it out on the highway and get up some speed, it runs okay, but if it cools off, it's like you are taking your life in your hands trying to pull out onto the highway. Please help!

Reply With Quote
  #2  
Old 01-31-2007, 07:36 PM
Registered User
 
Join Date: Aug 2006
Posts: 141
Sluggish

There are a lot of things that can cause your problem. Always check the baisics first #1-is it getting full throttle?,#2-is the basic tune-up OK?
#3-is the trans starting out in the right gear?
300Es are famous for fouling plugs due to worn valve guides and/or rings not sealing (pull the plugs after a cold start and see if they are oily)
All gasoline engine require more fuel when cold (maybe it's too lean)
The plugs need more voltage when cold and MBZ coils fail often.
Hope this gives you some ideas!
Mike
Reply With Quote
  #3  
Old 01-31-2007, 08:33 PM
Registered User
 
Join Date: Jan 2007
Location: Fairfax, VA
Posts: 2
Thank you!

Thanks for the advice, Mike. I will give this information to my husband and perhaps the mechanic can look into it. It has been a little hesitant for several years, but now when you push on the gas, it almost feels as if some sort of pressure or vacuum is pushing BACK against you ... like you're driving into a head wind or something. It's really weird, and really dangerous.

Thanks again, and if you think of anything else, please let me know.
Reply With Quote
  #4  
Old 02-01-2007, 05:37 AM
Registered User
 
Join Date: Aug 2002
Location: Southeastern PA
Posts: 3,035
peg777, it would help to know some additional information about your 1989 300E ... mileage and whether or not you perform routine preventive maintenance described in the Service Booklet. Sluggishness could be that it needs a variety of things ... fuel filter, spark plugs, distributor cap & rotor, ignition wires, coil, oxygen sensor, etc.
__________________
Fred Hoelzle
Reply With Quote
  #5  
Old 02-01-2007, 04:51 PM
Tony 12's Avatar
Registered User
 
Join Date: Jan 2004
Location: Barossa Valley, South Australia
Posts: 71
Hi!
My '88 260E has the same symptoms but obviously nowhere near as bad.
Over the last 6 months or so it has become sluggish at low engine revs. At higher engine revs (2500-3000 and over) it goes great.
I've done fuel filter, air filter, plugs, checked valve timing when I did timing chain.
I was wondering if injectors may cause this issue? Mine has done 250000kms and it has never had new injectors. I heard they may not last that long.
Anyone have an opinion on this?

__________________
Tony
76 W116 280SE
74 W107 450SLC
88 W124 300E
82 W123 280TE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page