Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-13-2001, 11:02 PM
Beatle Juice
Posts: n/a
When I turn the key to the on position I don't hear the fuel pump run. But it does run when cranking the engine. During this time the fuel pressure goes beyond 6 bar then stalls. I jumped the pins at the fuel pressure relay with a remote starter switch and can keep the engine running by turning the pump off and on, keeping the pressure between 3-4 bar. I have taken the pressure reg. out of the distributor and it seems ok. Does the relay have anything to do with the pump not running koeo, and what could be the cause of the high pressure?
Thanks for any help...
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Realy strong fuel odor in cabin... jriewer Tech Help 6 06-19-2004 10:09 AM
Mechanical Fuel Injection Pump not working properly M_Anker Vintage Mercedes 12 06-06-2004 12:40 PM
94 C280 starting help needed! Duke1Law Tech Help 1 06-13-2003 02:12 PM
1982 380SL fuel problem Benzene Tech Help 5 06-12-2001 10:47 AM
replacing fuel distributor,W124 BillFranklin Tech Help 4 10-05-1999 09:18 PM

All times are GMT -4. The time now is 03:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page