Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-14-2001, 03:42 PM
Posts: n/a
I have noticed that the M104 engine in my 1994 E320 wagon sits offset in the engine compartment. It doesn't sit directly 'north to south ' and the back of the engine appears to point towards the passenger seat by a couple of degrees off center. Is this normal and if so why did MB do this?
Reply With Quote
Old 05-14-2001, 04:13 PM
Glen's Avatar enthusiast
Join Date: Sep 2000
Location: Carlsbad, CA USA
Posts: 1,185

I'm not sure, here's a picture of the engine in my '95 wagon. Does it look the same to you?
Glen Tokuhara
Beauty & the Beast and the wagon that could!
Reply With Quote
Old 05-14-2001, 08:37 PM
Posts: n/a
Engine placement

The M104 in my '95 C280 sits just as you describe. It appears to be a little off centerline at the rear. Must be Ok. The photo provided by Glen appears this way also.
Reply With Quote
Old 05-15-2001, 05:47 PM
MBenzNL's Avatar
Join Date: Jan 2001
Location: the Netherlands
Posts: 1,417

This is a picture of the engine in my 300CE-24...

...looks pretty in-line to me...

1990 300SL-24
1993 C250D
with a minor 600+k kilometer
(the Netherlands)
Reply With Quote
Old 05-16-2001, 02:40 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352
I was looking under my hood and too noticed the slight 'mis' alignment. I never noticed it this thread was brought up. It must be normal then!

(BTW, door sills look GREAT!!)
2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 05-16-2001, 10:21 PM
Registered User
Join Date: Aug 1999
Location: ajax, ontario, canada
Posts: 773
looked under my hood, and the same is true for the M103 in my 190e2.6.

my guess is that this is done to align it with the pinion shaft of the differential, which is off-center, on the passenger's side.

never noticed it until this thread ...
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 10:53 AM
300E 2.8 M104 engine oil pan radunegru Tech Help 0 08-09-2004 05:06 PM
Rust Free 82 300SD in Dallas TX needs new home!!! bodyart27 Diesel Discussion 47 08-07-2004 08:54 AM
Bowden Cable Adjustment for M104 engine David C Klasse Tech Help 21 10-25-2001 09:49 AM
M104 engine (300/24) with ASR & cruise control... MBenzNL SL Forum 7 07-25-2001 04:43 PM

All times are GMT -4. The time now is 07:49 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page