Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-26-2001, 10:39 AM
Posts: n/a
When I turn on the A/C I get cold air out of the center vents and really hot air out of the side and defrost vents. Sometimes the A/C will work after 30 minutes or so of driving or if the outside air temperature is cooler.

Can someone help???
Reply With Quote
Old 05-26-2001, 10:54 AM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
You should locate the vacuum controlled water valve. It is in the cowl area more toward the passenger side.

Verify that vacuum control responds to inside controls. If vacuum is OK, verify the condition by using an appropriate device to squeeze the hose shut. This should shut down the water flow. If it solves all your A/C conditions you will have to replace the valve which is cheap (less than $20).

If vacuum is your problem you could cheat your way through the A/C season by running a straight vacuum source through a check valve to the heater valve. The point of the check valve is to keep the valve from opening when the throttle goes to the floor (and vacuum goes to zero).

Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 05-27-2001, 12:11 AM
Registered User
Join Date: Mar 2001
Location: SF
Posts: 201
Chris, See Igriffs post about his AC....
Reply With Quote
Old 05-29-2001, 11:10 PM
Posts: n/a
Thanks for the info stevebfl and ChinaClipper. I started troubleshooting this weekend and the weirdest thing happened. While in a/c mode and the air blowing cold through the center vents and hot through the exterior vent, I rolled the temp control to max heat. I let the system operate approximately 30 seconds and the rolled the wheel back to min. The air then blew cold out of all vents. This procedure has been working for the past few days but I would still like to correct the problem.

stevebfl - Is there anything that can be eliminated from the previous troubleshooting information?

ChinaClipper - Did you experience the same quirk?


Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1983 Mercedes 300d air conditioning scottlemoine Diesel Discussion 1 07-29-2004 03:43 PM
25 mins to go on ebay. urgent part question guydewdney Vintage Mercedes 1 10-11-2003 04:45 AM
Air conditioning '98 ML320 itb76 ML, GL, G-Wagen, R-Class, Unimog, Sprinter 0 08-29-2003 08:29 AM
Air Conditioning on a 16V Jr. Benz Tech Help 3 08-02-2002 04:49 AM
Will Alum 240D Air Cleaner Fit on 300D tcane Diesel Discussion 0 01-10-2002 07:33 PM

All times are GMT -4. The time now is 08:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page