PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   W210 Rough Idle (http://www.peachparts.com/shopforum/tech-help/187298-w210-rough-idle.html)

shailey 05-04-2007 11:27 AM

W210 Rough Idle
 
Hi, Folks,

I have a 2002 E320 with 68,000 miles on the clock. Last year, I began to notice a roughness or miss while idling on rainy days. The shop checked it over and couldn't find a reason for the condition. The problem just went away once the weather cooled off last fall.

Well, now it's back. Does anyone have a suggestion as to how to address this problem? There are no fault codes showing on my meter. Should I be concerned, or should I just consider this to be an idiosyncracy of this particular vehicle?

Thanks for your help.

ILUVMILS 05-04-2007 12:12 PM

I replace lots of ignition wires on M112/113 powered MB's with over 40,000 miles. The good news is that they run like new afterward. The bad news is that the wires aren't cheap.

ProV1 05-04-2007 06:32 PM

my guess is your MAF might be on its way out. try cleaning it or replace it next time u get new air filters

okc329 05-04-2007 07:56 PM

Rainy weather could be
 
causing an arc from a plug wire to a ground. When air is moist, it becomes more of a conductor. Put car in a dark garage and run engine while idling roughly. Look for arcing off of plug wire.

shailey 05-09-2007 08:28 AM

Followup......
 
Hi, Folks,

the rough idle turned out to be a miss on the #6 cylinder. My Indi, World Foreign Car in Richmond VA, replaced both spark plug wires and everything is fine.

Thanks for your help.

Steve


All times are GMT -4. The time now is 04:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website