Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-04-2001, 12:58 AM
Registered User
 
Join Date: Jun 2000
Posts: 60
The blower fan on my 90 300e has quit working. The A/C is working but the blower motor is not running in any position(Heat, A/C, or Defrost) I have looked at previous posts on this subject, and I have already checked the fuses in the fuse box as well as the fuse in front of the fuse box. I also noticed a post that indicated the ignition switch could be bad, so I tried moving the key around as mentioned in this post, but still no luck. Are there any other fuses I have not checked? Is there anything else before replacing the blower motor? Thanks in advance for your responses.

Ken Yancey
__________________
1987 300SDL
1990 300E
1989 300E
1986 300E
1981 300D
1983 240D
Reply With Quote
  #2  
Old 06-04-2001, 02:29 AM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
i hope it is not the regulator. paid big bucks
for parts and labor. an a/c specialist could easily
analyse it.
Reply With Quote
  #3  
Old 06-04-2001, 12:17 PM
Registered User
 
Join Date: Apr 2001
Posts: 45
Ken ... When mine quit working a visual inspection of the forward strip fuse would have led one to believe it was fine. I might suggest you replace it even thought it does look ok. The part is only a buck and a quarter. Can't hurt.
Reply With Quote
  #4  
Old 06-04-2001, 11:20 PM
Registered User
 
Join Date: Jun 2000
Posts: 60
Tom,
Thanks for the info, I replaced the fuse strip, but the blower is still not working. I do have power to both sides of the fuse strip in front of the fuse box.

Joel,
Where is the regulator located? Thanks for the quick response.

Any other thoughts?

Ken
__________________
1987 300SDL
1990 300E
1989 300E
1986 300E
1981 300D
1983 240D
Reply With Quote
  #5  
Old 06-04-2001, 11:28 PM
Registered User
 
Join Date: Dec 2000
Location: ny
Posts: 119
the regulator is located beneath the blower motor under the wiper assembly.It is not cheap however about 250$.the blower motor is about the same price.They are located next to each other so after digging them out you must determine the part at fault
Reply With Quote
  #6  
Old 06-04-2001, 11:57 PM
Registered User
 
Join Date: Jun 1999
Location: Surrey, Beautiful British Columbia, Canada
Posts: 750
Ken - check out http://www.mercedesdot.com/newsletter/issue8.htm on how to take it out. it you have the time to do it, do it.
labor is also expensive.

[Edited by joel on 06-04-2001 at 11:01 PM]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Notes may help people: Radiator, Fan Clutch, Temp Sensors, Fuel Pump, Temp Gauge ericgr SL Forum 3 09-24-2004 02:40 AM
W124 300TE A/C Blower fan is not working when the car is running ke6dcj Tech Help 2 10-21-2003 10:07 PM
No blower fan on 300TE someguyfromMaryland Tech Help 8 08-28-2001 06:39 AM
Auxillary Fan not working on 300sd DP Diesel Discussion 2 06-25-2000 09:23 AM



All times are GMT -4. The time now is 01:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page