PeachParts Mercedes ShopForum

PeachParts Mercedes ShopForum (
-   Tech Help (
-   -   300E 2.8 sometime starts, sometimes doesnt start (

jaime 06-04-2001 08:09 AM

My 1993 300E 2.8 starts fine most of the time, but sometimes it does not. the starter will move the engine just fine but there is no electrical current to the sparks plugs. this happens when trying to start with the radio & A/C on. now the weird part is that if the A/C is turned off it will start just fine. also, if the drivers side door is locked and unlocked it will start alright. i think it has to do with the alarm system cutting current to the engine. any thoughts?

G-Benz 06-04-2001 11:19 AM

Is this an aftermarket alarm system? I had an aftermarket system in a Jag that started sucking the battery dry when parked because of a faulty brain. Ripped that sucker out and the problem went away.

I would have led you to the OVP relay, but since you can get the car to start by switching the A/C off or unlocking the car, it seems like the fault is the "non-factory" component, namely, the alarm.

jaime 06-04-2001 01:04 PM

I dont know if the alarm in our car is factory installed or dealer installed (this is my mother's car and i was away on college when it was bought new). I think it's factory installed item. anyway, what does the OVP relay you mentioned do?? Where is it located at?? Thanks

G-Benz 06-04-2001 02:00 PM

Ah yes the OVP. Stands for Over Voltage Protection relay. It's main function is to shunt the circuit whenever it senses a input voltage that is greater than nominal. Protects the sensitive computer circuitry.

Before you ask, it's located behind the battery. There is a black plastic shroud that you can just push forward and lift out of the way, which will reveal a few electrical components. The OVP is a silver rectangular unit with a clear plastic top, covering one or two red (or green) fuses inside, depending on your model year.

I replaced mine in my 300E a few months ago after getting some intermittent starting problems, and that cured it.

I have read threads where the OVP was the source of anything from starting problems to ABS light coming on.

Anyway, I am hardly an expert when it comes to this stuff, I can just share from experience. But if you do a search on "OVP", you should find a ton of information about it.

jaime 06-05-2001 10:49 PM

thanks for your advice. I got the OVP relay today for $65, put it in, and the car hasnt given any prblems (at least not today). It looks like that was the problem, but I'll be watching it closely to see if it behaves. thanks again


1998 E430 silver/gray
1993 300E 2.8 white/tan
2000 Toyota Celica GT-S black/black

All times are GMT -4. The time now is 06:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website