Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-24-2007, 08:49 PM
Registered User
 
Join Date: Jun 2007
Posts: 1
Unhappy 1994 c280

the shop had to replace the ignition key/switch and had to re-key..I picked up the car and tested all keys and they seem to work. Parked the car in garage and the following day, none of the keys work and all I get is a SRS no codes..The key can turn to the on position but the lights on thepanel do not come on..Any cluses????thanks in advance for input...By the way, this wasn't a Benz dealer who did the new keys...
dragonrb

Reply With Quote
  #2  
Old 06-25-2007, 02:18 PM
Registered User
 
Join Date: Oct 2006
Posts: 55
disconnect the battery

i know this sounds odd - but try to disconnec the battery for about 30 mins. i had something similar happen with my c280 and i left it sit for 30minutes w/out the battery hooked up and it solved the problem.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page