Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-12-2001, 09:17 AM
Registered User
Join Date: Jan 2000
Location: Chesapeake, VA
Posts: 396
This is tough since I am working at a distance (my son has the car approx. 200 miles away). There is a loud screeching noise, apparently from the engine compartment, on cold start up only. Shifting from Park to Reverse or Drive silences the sound (not instantly, more of a winding down sound). Since the sound is coming from the engine compartment and I recently renewed the belt, water pump, fan bearing bracket, idler pulley and tensioner pulley I don't suspect the belt drive. Could it be the AIR pump (NOTE: On this car it is not belt driven-it's apparently driven by an electric motor). When does the pump function? On a hot or warm start there is no problem.
Reply With Quote
Old 06-12-2001, 04:56 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The air pump only runs when the engine is cold, and maybe once in a while on decel to check function of the pump. There is a 2 pin electrical connector for the pump under the plastic cover at the front of the valve cover. Could be un-plugged 1 morning to test.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is my air pump? 94 c280 jlomon Tech Help 3 03-19-2005 07:26 PM
Failed emissions: no Air Injection Pump? pistolpete5113 Tech Help 10 11-11-2004 05:07 PM
Mass Air Senson, '92SL c4791p Tech Help 7 10-17-2004 01:20 PM
83 300TD 300d Air Bubbles in fuel lines hand pump? no start bmitchell510 Diesel Discussion 5 12-27-2003 11:09 AM
C280 air flow control Golden Luck Tech Help 1 08-18-2001 10:20 PM

All times are GMT -4. The time now is 05:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page