Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-13-2001, 04:31 PM
Registered User
Join Date: Jun 2001
Posts: 259
Had a slightly disturbing experience yesteday in that coming to a stop, I had to really stand on it to get my 380SL to stop. Since I was 150 miles from home, I had no choice but to pull into the nearest lube place and had the brakes bled. I have just recently had new pads installed.

Anyway, the bleeding worked but only for a few short blocks but I made it home anyway. Took to to a mechanic that works on my car and he came to the conclusion that the MC was bad (although no leaks could be found.) He swapped it out for me but with not much change in the stopping power.

Now we think it might be the power booster as it seems to come and go.

What can be done to check the the booster and the vacuum to diagnose this. Any help would be appreciated.



Reply With Quote
Old 06-13-2001, 06:31 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I had to make a test pipe for this. I used an old hose to check for vacuum under stopping condition. BE SURE THAT THE VACUUM BOOSTER HOSE IT WELL CONNECTED AND THE VALVE IS NOT CRACKED.
Donnie Drummonds
Reply With Quote
Old 06-14-2001, 08:48 AM
Registered User
Join Date: Jun 2001
Posts: 259
Identify the valve please?

Do you mean the check valve about the size of a quarter that connects the two hoses? When I push the brakes I hear air wooshing--is that a normal noise?


J. Boggs
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W202 Brakes - Long Pedal Travel elegance4 Tech Help 16 03-04-2004 02:52 PM
HELP, Brakes nobs690 Tech Help 11 02-02-2004 12:54 PM
Does the new C230K have the C32 Brakes?!!! zeronero Performance Paddock 14 12-07-2003 03:19 PM
Anti-lock Brakes working when not supposed to.... RLNAMERCEDES100 Diesel Discussion 1 07-23-2002 07:15 PM
Upgrade brakes or rims? JCE Performance Paddock 5 06-08-2000 02:37 PM

All times are GMT -4. The time now is 08:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page