Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-13-2001, 09:40 PM
Posts: n/a
the air conditioning stared working intermittent. thenit had just quit. now the defroster is on all the time & the blower does not work. the aux. fan also does not work. i can not find a hot wire to the air & heater controls. someone told me it could be a vaccum problem, but i think it is some thing electicial. i checked terminal x4 & terminal x30. where is terminal 15r. my books do not have all the brake downs. thanks barry
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 300 SEL AM/FM/CD Upgrade? rbellamy1 Car Audio and Multimedia 2 07-31-2003 11:35 AM
Pre-purchase Opinions Sought: 1988 300 SEL rbellamy1 Tech Help 8 07-25-2003 11:55 PM
1988 300 E blower for heat and ac not working Bigchat1 Tech Help 0 05-10-2002 02:17 PM
Tranny for 300 SE 1988 yagua Mercedes Used Parts For Sale & Wanted 0 02-27-2002 01:26 AM
A few 1988 300 CE issues JeremyAllen Tech Help 27 04-26-2001 09:59 PM

All times are GMT -4. The time now is 10:16 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page