Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-13-2007, 09:44 PM
Registered User
 
Join Date: Sep 2004
Posts: 96
More Power Steering Pump Questions.

I have an old vickers power steering pump on my 1984 380sl and I have two questions. When you reseal the pump and reinstall it do you have to prime the pump and if so how do you do it? Also there is a plug to the right side of the pully (see thumbnail) It is about an 1 to 1 1/4 across, what is under the plug? Could it be a pressure regulator. Something is keeping the pump from moving the fluid and I have checked everything else? Anybody have any thoughts?
Attached Thumbnails
More Power Steering Pump Questions.-000_0148.jpg  
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page