Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-14-2007, 08:36 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
massive leak after overheat

Son's 300e overheats.

Replaced fan clutch which is shot...replaced belt. Did motor mounts, too..but that's another story.

put it all back together...running smoothly.

Take it for a run....

Come back ....massive leak under the water pump area... it got dark and the water was hot so we stopped working.

Shut car off... just drips from that area.

Will check tomorrow...

oh....also aux water pump was making noise... it probably blew a bearing or something during the initial overheat.... any way to check it?


i know about a weep hole...but this was like a blowout...almost like a hose is disconnected....

a/c didn't work either...but that's probably because water is dripping on the belt and making it slip.

I guess the big question is.... is there a freeze plug down there that could have blown out.

I would normally be able to answer these questions, but it got too dark, too fast.

thanks.

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #2  
Old 08-15-2007, 08:12 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
No freeze plug in that area..most likely a blown w/p seal.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 08-15-2007, 09:06 AM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
thanks, mb doc.

probably melted the damn thing on the overheat....

Water pump sounds fine, but will replace

first repair issues with this car in 2 1/2 years and 30k miles. It's a shame my son didn't watch his gauge a little closer.

i have read and re-read the water pump replacement.

i think i will take out the radiator and fan just to have a lot of breathing room, move the steering pump to the side ...and pull out the tensioner..

wish i didn't have to mess with that tensioner.
__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #4  
Old 08-15-2007, 11:58 AM
Registered User
 
Join Date: Jun 1999
Location: Albuquerque, NM USA
Posts: 1,946
Quote:
Originally Posted by lee polowczuk View Post
probably melted the damn thing on the overheat....
Actually, this was probably cause of the overheat.
__________________
Kent Christensen
Albuquerque
'07 GL320CDI, '06 SLK350
Reply With Quote
  #5  
Old 08-15-2007, 12:42 PM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,580
Quote:
Originally Posted by lkchris View Post
Actually, this was probably cause of the overheat.
Could very well be just that. System is pressurized, If pressure is lost, car overheats.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #6  
Old 08-15-2007, 01:07 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,632
thanks....

at least the engine appears to be fine..

on another note: What a difference new motor mounts make, really unbelievable..

I need to do those on the CE

__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page