Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-26-2007, 04:21 PM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
93 190e 2.6 Auto Trans Prob- All gears are like neutral!

Ok so im driving going 30 and suddenly my rpms shoot way up like i shifted into neutral. I pull over and put it in park. Park engages just fine and locks the driveshaft. I turn it off, then back on a cycle through all the gears and every single gear is like neutral! So i check for leaks, nothing. Check the fluid level and it is really high on the dip stick, but it has never over flown or anything. I just got done putting a new 2.6 engine in and i used my old tranny. I filled the TC before installation, cycled through the gears while adding ATF, changed pan gasket and filter.
Any idea what could cause it to behave like this?
THANKS

__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
  #2  
Old 08-26-2007, 05:04 PM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
only thing i can think of is that i used full synthetic fluid... not sure if that would cause something huge like this to happen
__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
  #3  
Old 08-26-2007, 05:57 PM
Registered User
 
Join Date: Jul 2007
Location: USA
Posts: 2,156
vacuum leaks at the modulator on the tranny is where I would first start. It could be something internal which means its cost you some money. It also could the modulator on the tranny. to get at it you are gonna have to remove the tranny. I haved a removed a tranny from a 91 190E 2.6 and the hardest part is getting it out, installing isnt so hard. You will need many extensions and a breaker bar to losen them up.
Reply With Quote
  #4  
Old 08-26-2007, 06:11 PM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
Yeah, i just took a look at that elbow connector on the trans. Seemed ok, hopefully its not loose. My first thought was vac too, however i thought that when you have a vac leak, it just doenst shift out of certain gears and reverse doesnt work. I dont think a vac leak would take out your entire gear selection.

I drained a half quart of fluid and ran the magnetic retrieval tool through it. No metal shavings. Just a strange swirl pattern when you stir it. Could be the old fluid not mixing well with the new synthetic?
__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
  #5  
Old 08-26-2007, 07:29 PM
Registered User
 
Join Date: Sep 2006
Location: New Orleans LA
Posts: 93
trans

vacuum nor the modulator control the trans to make it engage they
only control shifting. a bad pump or a valve body can do what you are talking about
__________________
Keeping 'em Running
1990 300SEL
1994 E320
1989 E300
Reply With Quote
  #6  
Old 08-26-2007, 08:33 PM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
ok i pulled the cooler hoses at the rad. The upper was dry, we started the car and nothing came out. The lower had some residual fluid in it, however once that drained we started the car and nothing came out. The vacuum line to the intake manifold is dry, no tranny fluid
__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
  #7  
Old 08-26-2007, 08:50 PM
Registered User
 
Join Date: Oct 2005
Posts: 4,263
It sounds like you lost the pump.
Reply With Quote
  #8  
Old 08-26-2007, 08:57 PM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
The pump? I assume this is inside the tranny and expensive to fix, yes?
__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
  #9  
Old 08-26-2007, 10:57 PM
Registered User
 
Join Date: Jul 2007
Location: USA
Posts: 2,156
Yeah your problem is internal and will cost you a few bucks. I had something similar to my 91 190E and would shift out of 2nd. The modular was working and no vacuum leaks. turned out to be something internal. A rebuilt tranny was cheaper so I went with the rebuilt.
Reply With Quote
  #10  
Old 08-26-2007, 11:06 PM
Registered User
 
Join Date: Jan 2002
Location: NY
Posts: 500
Make sure the torque converter still connected to the engine. Did you torque these bolts after engine replacement?
Mike
Reply With Quote
  #11  
Old 08-27-2007, 01:52 AM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
yeah i torqued them really good. Im going to drop the pan tomorrow and see if the filter or anything is clogged. Is the tranny pump a DIY or shop material? I assume you have to drop the trans to do it either way? I got a beater car with a great trans i can use if need be. thanks for the responses guys. Any tips on pulling the tranny with the engine still in? I just did a whole engine swap, so im pretty comfortable but any tips would be nice!
__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
  #12  
Old 08-27-2007, 11:23 AM
Registered User
 
Join Date: Jul 2007
Location: USA
Posts: 2,156
to remove the tranny you will need many extenisons to reach the bolts on top of the tranny. I suggest a break bar as well. I also suggest having an someone help guide the socket on the bolts on top since you cant really see them to well from below the car.
Reply With Quote
  #13  
Old 08-27-2007, 11:40 AM
david s poole
 
Join Date: Mar 2005
Location: dallas
Posts: 1,822
sounds like pump,easy check---check fluid on dipstick with engine off then start engine and try again----level should go down if pump working.could also be one of the ears on torque converter.
__________________
David S Poole
European Performance
Dallas, TX
4696880422

"Fortune favors the prepared mind"
1987 Mercedes Benz 420SEL
1988 Mercedes Benz 300TE (With new evaporator)
2000 Mercedes Benz C280
http://www.w108.org/gallery/albums/A...1159.thumb.jpg
Reply With Quote
  #14  
Old 10-24-2007, 02:31 PM
chuni959's Avatar
Registered User
 
Join Date: Jan 2003
Posts: 396
are you KIDDING ME! It happened again
UGHHH My car just ate through 2 trannies in a week- car is all stock HELP
i HAVE to be doing something wrong here guys

__________________
1993 2.6 (040) SportLinE 5-speed - Armed to the teeth w. roof rack/2x bike carriers/8x ski carriers/MB towing bumper
1993 2.6 (040) - deceased/reincarnated as a trailer.
1987 16v (702) - Now parting out(9/22/10)!!! - Email me your requests for 16v parts- Engine and full body kit avail!!
1987 300SDL (122)- For sale!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page