Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-26-2001, 12:08 PM
Registered User
Join Date: Sep 1999
Location: SW Colorado USA
Posts: 296
I have had a problem with the 3.2 M104 engine in my G for a while now. It started out as low power below 3500 rpm with a decided jump in power right at 3500. Now the low end seems even weaker and I have a stumble just off idle. Similar to an old V8 with a bad accelerator pump in the carb. I have checked the flap valve in the intake, the vacuum line is connected and the door opens when vacuum is applied. I was also thinking the throttle position sensor. This may explain the hesitation but may not cover the low power because the rpms, not the throttle position, cause the power fluctuation. Pretty technical I know, just fishing for possibilities.
1995 G320
1984 280GE
1971 Unimog 416
Reply With Quote
Old 06-27-2001, 12:17 AM
Posts: n/a
bosch copper electrode spark plugs gapped to .040 inch (1mm)
Reply With Quote
Old 06-27-2001, 12:24 AM
Join Date: Jan 2000
Location: Indpls.,IN. USA
Posts: 84
It sounds like ignition to me. I would carefully inspect the plug connections and coil leads. It might be helpful to look at these in the dark and spray some water on the ignition at the same time.
Good luck
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
M103 hard start, rough idle, hesitation SOLVED tryan Tech Help 9 02-12-2003 05:00 PM
rough idle; low idle rpm AAL Tech Help 4 09-16-2002 03:38 PM
Low idle engine speed Jackd Performance Paddock 12 05-12-2002 10:53 PM
'91 190E 2.3 rough, low idle - fixed sbourg Tech Help 0 08-19-2001 01:17 AM
190E low idle and loss of power vagrant77 Tech Help 3 04-26-2000 09:50 PM

All times are GMT -4. The time now is 12:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page