Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-12-2007, 03:56 PM
Registered User
 
Join Date: Sep 2005
Posts: 15
1986 190E 2.3 16V has very high idle

I have a 2.3 16V that has an intermittent high idle problem. Every once in a while, the car would idle at 2800-3000rpms. Unplugging and plugging in the ecu will temporarily fix the problem. I've tested the idle valve, air flow sensor, eha, all sensors, micro switches, and components and did not find any problems. When idle is high, voltage from the ecu to the idle valve is at battery voltage. Also, not sure if it's related, but the lambda control will show to be inoperative when the problem is occurring. I've changed the ecu with an rebuilt unit, but it still has the same problem. Any ideas what i should check next? I'm still thinking we received a bad rebuilt ecu, but would like everyones input before i put in another ecu. Thanks for all your help. Thanks

Simon

Reply With Quote
  #2  
Old 09-12-2007, 09:50 PM
Registered User
 
Join Date: Aug 2001
Location: Houston, Texas
Posts: 393
I am not familiar with this car, my comments are based on my 87, 260E. How about the accelerator mechanism sticking so that the idle switch is not coming on ? Or the idle switch is failing intermittently ?
__________________
Saumil S. Patel
Reply With Quote
  #3  
Old 09-12-2007, 09:50 PM
Registered User
 
Join Date: Aug 2001
Location: Houston, Texas
Posts: 393
I doubt that it is the ECU itself.
__________________
Saumil S. Patel
Reply With Quote
  #4  
Old 09-12-2007, 09:57 PM
slk230red's Avatar
WECO Installer
 
Join Date: Jul 2006
Location: Tampa, FL
Posts: 819
Quote:
Originally Posted by gsr355 View Post
I have a 2.3 16V that has an intermittent high idle problem. Every once in a while, the car would idle at 2800-3000rpms. Unplugging and plugging in the ecu will temporarily fix the problem. I've tested the idle valve, air flow sensor, eha, all sensors, micro switches, and components and did not find any problems. When idle is high, voltage from the ecu to the idle valve is at battery voltage. Also, not sure if it's related, but the lambda control will show to be inoperative when the problem is occurring. I've changed the ecu with an rebuilt unit, but it still has the same problem. Any ideas what i should check next? I'm still thinking we received a bad rebuilt ecu, but would like everyones input before i put in another ecu. Thanks for all your help. Thanks

Simon
I've been diagnosing my '93 2.3 for the opposite reason, the idle is too low when A/C is on and the car is in drive. I have battery voltage (12.24v) on pin 2 of the idle control valve, but not full ground on pin 1. If I ground pin 1, the idle goes real high.
When your car is running, what happens if you disconnect the power connector at the idle control valve?
__________________

1993 190E 2.3
2001 SLK230
1971 LS5 (454) Corvette Convertible
Reply With Quote
  #5  
Old 09-13-2007, 01:42 AM
Registered User
 
Join Date: Sep 2005
Posts: 15
If i disconnect the plug at the idle valve, the idle will drop back to normal level. Also, if i disconnect the air flow meter plug, the idle also drops to normal.
Reply With Quote
  #6  
Old 09-13-2007, 02:25 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,038
I would still suspect the Idle Air Control Valve. I would refer you to TheRev (www.190revolution.net) but it appears to be down for the count.

I know when I first start my 2.6 it'll idle at ~1000 then once i put it into Drive it'll drop to 650ish.

Your idle problem does it occur in just in Park? Or does the gear not matter?
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #7  
Old 09-13-2007, 11:08 PM
Registered User
 
Join Date: Sep 2005
Posts: 15
gear does not matter. it's has a manual transmission, but when it has the problem, it'll do it all the time.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page